Having connection issues with ioT2020 and node red

#1

I have created my first project, which is a work base project utilizing the Siemens ioT 2020, where i am running a simple flow with a signal from my ioT 2020 to print a number in the debug screen. I have my ioT running on our HTTP network, followed all correct steps to set up all software and devices. When I run the project for the fist time it will run fine but if I change and have to re-deploy it will drop out with a " Lost connection to server error ". The board will not even register in the 'digital output' node settings.
Resetting and sometimes powering down the ioT is the only way to get it working again. When it is running it runs fine.
Pulling my hair out here so any advise or guidance would be greatly appreciated.
Many thanks

0 Likes

#2

Please donĀ“t get me wrong but also have a look at the Revolution Pi device. It is compatible with the standard Raspberry Pi and runs a pimped Raspian and therefore you may have better support in case of OS and installed software.

Advice to your problem: run node-red manually on command line and have a look at the debugging output during deployment.

0 Likes

#3

Thanks for your recommendation. That will be the way I will be going in the future but this is the unit work have me using.
As for your advice I don't follow walhatvypu asking me to do. I tried following but cannot see anything different when deploying.

0 Likes

#4

Is a proxy server in your browser settings?
Did you try different browsers? (Chrome recommended)
Do you use the Nide-RED projects feature?

0 Likes