Help for https command

#1

Hello
I use a device with wich it is possible to communicate with https requests.
So, I tried to use the http or even the https node (https contrib installed in adition to the stanard http)

Here is the command I need to send :slight_smile:
https://admin:mGuard@192.168.10.21/nph-status.cgi?path=/network/modem/stat
When I send this command with Chrome, for example, I get e reply as

/network/modem/state=offline

But i don't know exactly what to put in wich field of the http or https node.
For example, POST, GET, etc... ??? What must i use?

Most of times, no matter wich syntax I use, I get this

27/03/2019 à 13:49:00node: 42c0a453.10ba4cmsg : error

"Error: unable to verify the first certificate"

27/03/2019 à 13:49:00node: 9a301fb3.52958msg : Object

object

_msgid: "a924557a.af9918"

topic: ""

payload: "Error: unable to verify the first certificate : https://admin:mGuard@192.168.10.21/nph-status.cgi?path=/network/modem/state"

statusCode: "UNABLE_TO_VERIFY_LEAF_SIGNATURE"

27/03/2019 à 13:46:54node: 9a301fb3.52958msg : Object

object

_msgid: "3294fd59.2b82f2"

topic: ""

payload: "Error: unable to verify the first certificate : https://admin:mGuard@192.168.10.21/nph-status.cgi?path=/network/modem/state"

statusCode: "UNABLE_TO_VERIFY_LEAF_SIGNATURE"

Can you help me, first to know what I must write in each field of the node, and then, if something specific must be done to send an https request.
Thanks

0 Likes

#2

Seems like the device has a self signed certificate. Either that or the certificate is invalid for whatever reason. When you are testing in Chrome ( which is a GET request by the way) do you (or did you earlier) have to approve the certificate first?

0 Likes

#3

Hello RealJax.
Yes, using chrome, before I send this request, I had to aprove the certificat.
And I confirm this is a self signed one.
How can I handle this in nodeRed?

0 Likes

#4

Don't think you can. But maybe this page can help you further:

0 Likes

#5

You can use LetsEncrypt to provide yourself with a valid certificate. It is not difficult.

0 Likes

#6

The problem is that the device being talked to only seems to accept ssl connections ( which is rather odd I think) and then LetsEncrypt is not going to help.

Maybe putting the device behind a reverse proxy like Nginx first might work.

But @mike67 , assuming the device you speak of is a an MGUARD-router, have a look at this router settings to see if there's a way to disable SSL acces. ( and while you're at it, also change the default password :slight_smile: )

0 Likes

#7

Hello
Finally that works
In fact, it was jest necessary to renew
the certificats.
And the Method is GET with user authentication

Thanks for your help

0 Likes