[Help] Funny npm errors that i have no idea how to fix


at the moment I'm trying unsuccessfully to install the node 'node-red-contrib-smartnora' for my Google Nest integration.

NodeRed is running on version 2.0.6.

Here is the log that is shown to me about the problem:

2021-09-28T18:32:23.904Z Installieren : node-red-contrib-smartnora 1.5.0

2021-09-28T18:32:23.012Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-contrib-smartnora@1.5.0
2021-09-28T18:32:48.037Z [err] npm ERR! code EBADENGINE
2021-09-28T18:32:48.063Z [err] npm ERR! engine Unsupported engine
2021-09-28T18:32:48.063Z [err] npm ERR!
2021-09-28T18:32:48.067Z [err] engine Not compatible with your version of node/npm: cbor@8.0.0
2021-09-28T18:32:48.067Z [err] npm ERR! notsup
2021-09-28T18:32:48.077Z [err] Not compatible with your version of node/npm: cbor@8.0.0
2021-09-28T18:32:48.077Z [err] npm ERR! notsup Required: {"node":">=12.19"}
2021-09-28T18:32:48.077Z [err] npm ERR! notsup Actual: {"npm":"7.24.1","node":"v10.19.0"}
2021-09-28T18:32:48.167Z [err]
2021-09-28T18:32:48.167Z [err] npm ERR! A complete log of this run can be found in:
2021-09-28T18:32:48.167Z [err] npm ERR! /home/pi/.npm/_logs/2021-09-28T18_32_48_085Z-debug.log
2021-09-28T18:32:48.205Z rc=1

if you need further information, just say it out loud.

Any ideas? I would be very thankful!

Not really funny at all. The smartnora node requires Node.js v12.19 or above and you are running on v10.19.0 which is no longer under support anyway.

Thank you so much for clearing up that gibberish for me! :slight_smile: