Help with a possible server problem


I’ve been using node red for around a year now with no problems at all and love ir

This evening i found all my many flows had stopped working and when opening any server related node I am getting a list of messages saying “You probably haven’t deployed since adding a server …you may have to do this to get auto fill working.”. So I laboriously re-deployed every node but no joy, it still happens, ie flows not working and no auto-fill.

I hadn't done anything with my HA server but I did update HA to the latest release 2021.1.4

I then tried a couple of previous snapshots (both full and partial), uninstalled node red and reinstalled. I’ve switched off the node “cache autocomplete results” option but still cant fix this.

I’ve re-installed Node Red again and still the same problem, maybe something to do with its connection to the HA server but I’ve checked my settings and cant find the fault HELP!!! :slight_smile:

Any ideas?



That's not a message from Node-RED. Probably best to ask on the HA Forum unless someone here knows.

Thanks dceejay will do

Hi all,

I’ve managed to get it working again but I’m not sure exactly what the solution was.

After re-installing node red for the second time I deleted all flows (they re-appeared when starting node red) I also deleted all unused nodes (something I didn’t know how to do previously). I then restarted node red and made a snapshot. After a HA restart I found node red was fully working again and was able to import my flows (which I had exported previously) and after some some routine setting up all is well again.So another snapshot was taken just in case!

I still don’t know why it broke or exactly how I fixed it but am happy again now :slight_smile:



This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.