How to ngrok dashboard ui

#21

Thanks Colin, yes it does, but I followed some tutorials and made the problem is even worse, wiping sd card with fresh backup image and will give you the results when setup again.

My question hasn't been answered and maybe the whole problem, do I append the proxy code [andrei-tatar] gave me to nginx.conf or overwrite or comment out something? I have never tried a reverse proxy before and the first time I have touched nginx.

#22

Sorry I can't help with the fundamental problem, I just knew where to find the error log so hoped that might help. I haven't used nginx in that way. I setup a VPN on one of my Pis for remote access which I found fairly simple and works well, for me anyway. In case anyone is interested:
http://blog.clanlaw.org.uk/2016/07/30/A-complete-vpn-server-for-under-20-ukp.html

#23

2019/02/02 22:18:59 [emerg] 1543#1543: "server" directive is not allowed here in /etc/nginx/nginx.conf:87

#24

Probably there is a missing } or something similar in the file.
Can you post your config file if you can't see the problem. Put a line with three backticks on before and after it here so that the forum doesn't mess up the formatting.

#25

Solved it, I decided to give one last shot before doing an Iframe within html, very happy I did.

Here, for the record, is how to do a reverse proxy with nginx with raspbian:

sudo apt install nginx

cd /etc/nginx/sites-available
sudo nano reverse-proxy.conf

#Paste the following

server {
       listen 3000;
       listen [::]:3000;
       location / {
              proxy_pass http://localhost:1880/ui/;
       }
}

sudo ln -s /etc/nginx/sites-available/reverse-proxy.conf /etc/nginx/sites-enabled/reverse-proxy.conf

sudo systemctl start nginx
sudo systemctl enable nginx

#Command to see what ports are now open
netstat -tupln

#use ngrock
./ngrok http -auth='username:password' -region au 3000

1 Like
#26

Check serveo it's a great tool

#28

Yeah I checked serveo out but it said it was 64 bit so I didn't try it since I wanted to use it on raspberry pi

#29

Use triple backticks around the code block.

```
Left aligned
    indented
```
#30

Thank you someone did mention that earlier, must have misread and used 2 back ticks instead

#31

Followed this to the letter, but when I run the last line I get:
-bash: ./ngrok: No such file or directory

Any ideas? I'm taking it you isntalled something else along the way that I don't have...

#32

I've actually taken a slightly different route for my dynamic DNS, but I'm still using the nginx setup above.

Am I correct in saying the only thing available on port 3000 with the above setup is the dashboard and the editor is not accessible?

#33

Just try /home/pi/ngrok http 1880
Check also that ngrok has properties (X) executable

#34

Sorry for lack of response, life has been busy. This post was intended for people having trouble using default ngrok with node-red as I was, I still don't understand why it was only me that was having trouble. Default ngrok may work just fine for you

Here is a link how to get started with ngrok https://ngrok.com/download

I strongly recommend using user/password option at all times if you haven't already set up node-red-admin, having devices naked on the web is never a good idea, no matter how short you imagine the time, there are a terrifying number of bots just looking for open systems out there.