Dashboard UI is running but flow editor webpage is blank

This is a headless PiZeroW running Raspbian 9 and a node-red flow. The dashboard UI is displaying and working correctly, it shows the status of Bluetooth LE "beacons" as present or absent, so I know the flow is running. But I noticed the node-red editor web page is blank. I've an essentially duplicate system out in the garage and its all working as expected.

I'm at a loss as to what to do. Perhaps ssh in and reboot? How can this happen? I've tried re-opening the editor at :1880 in a new tab and still nothing.

If I open in new tab the "image error icons" in what should be the leftmost pane I get:

Cannot GET /red/images/node-red.png
Cannot GET /red/images/spin.svg

I've never seen anything like this before.

What is the full address of the dashboard?
if you ssh in, can you see anything on the log? (use node-red-log)

I couldn't ssh in :frowning:

I will pull the plug and reboot eventually.

The full address of the dashboard is:

ping beconpi works, but ssh pi@beaconpi fails with:
ssh_exchange_identification: read: Connection reset by peer

Try beaconpi.local:1880 or use the actual pi addres

These made no difference.

When I cycled the power it didn't reboot.

Hooking it up to my test jig with KVM if failed to boot but the monitor showed lots of Failed! when starting services.

Troubleshooting now.

Looks like the SD card died or somehow became "corrupted". I "cloned" a new SD card from my "master copy" and all is working fine again.

Weird that node-red partially worked -- the entire reason for having the PiZeroW computer still worked, but but pretty much nothing else did. It'd have been a horrible death at the next power outage. I just happened to look at its node-red editor to jog my memory about how I'd done something and discovered the problem, no telling how long it had been fubar.

Well that was lucky and good thing you had a backup!