How to solve HTTP - Request error

I have a issue with solving HTTP-request error

using following request in the browser returns a usable data string
https://192.168.0.74:1443/api/config/flags

But in node red there are alarms I can't solve
For example with this version I got ECONNRESET error

debug window:
image

It would be helpful if you names all your nodes. That way the name will showup in the dwbug log instead of an ID

The unexpected token message probable comes from the json node telling you the data sent to it is bad. Add a debug node (set to display the complete msg object) to the the output of the http to show what it is getting.

Thanks

I added names and a debug node. Looks like the issue is with unable to verify the first certificate?

Why it works in the browser??
Here the output from the browser

here the http request

Info if set to display complete msg object

image

Looking at the url from the screenshot you shared it seems that you are using a self signed certificate ?

The following from the http request nodes Help tab :

image

so set in your Http request node the url to be https:// ... (in the first screenshot you had it http)
and also the above option msg.rejectUnauthorized = false (set from the Inject node)

yeah, I tryed both as i don't understand the issue

the above option msg.rejectUnauthorized = false (set from the Inject node)

Is that using msg.payload? and which type?

I tried a few combination but no success

Thanks

I saw that you were triggering the http request from an Inject node so have you tried this

image

I tried like in the pic but it say invalid property expression
image

that must be for the msg.topic field that you have not set correctly and its highlighted in red.
just press X to remove the topic row (or fill it with a valid value if you need to)

1 Like

sorry...
i got it to work (see picture) but same result in the http request

image

nope its not correct
node-red nodes expect their msg. properties and values to be very specific

does that look like the image i shared above ? :face_with_monocle:

If you are new to node-red, watch this video playlist for gettting started with the basics
Node-RED Essentials

I'm so sorry and thanks for the pation. now it passes !! You made my day :grinning:

1 Like

Hi this is Palak Sharma.
Well for this you can clear your browser cookies with clearing DNS cache.
It may resolver your problem, if still have this problem or will come in future you must try it.
Thanks