I am new to Node-RED and I am trying to load the csv file from windows in my Node-RED but the file is not found

Error: ENOENT: no such file or directory
I am using Node.JS version :v16.14.0
and Node-RED version: v2.2.2

In windows, you have to use \\

e.g a file called C:\myfolder\myfile.csv needs to be accessed using C:\\myfolder\\myfile.csv

[edit] I used to think this was true but it doesn't seem to be for this node at least :confused:

Thank you for your response. I have tried that too.
But the error is still the same with double Backslash:
"Error: ENOENT: no such file or directory, open 'C:\Users\ACER\Desktop\auroral project\csvFiles\siteinfo.csv'"
Do you have any idea on this??

can you move the file into a folder without a space in its name?

Does it work then?

Note - in the forum if you want to get \\ to show up, you have to type \\\

[edit] Just tried on my Windows 11 machine

And it actually works without \\ as well which was a bit surprising :slight_smile:

I tried to copy the file, make a new folder and use it without space.
It doesn't seem to work.
"Error: ENOENT: no such file or directory, open '"C:\\csv\\siteinfo.csv"'"

This seems surprising. I am trying to do the same thing for a while now.
May be I have to start the entire process again.
Thank you very much for your effort. :slightly_smiling_face:

In Windows you can use either forward or back slashes, so in node-red use forward slashes and that makes life simpler,

If you are putting a filename into a field in a node then the double backslashes should not be necessary. It is when you are defining a string in javascript that you have to escape it. But by far the simplest is to use forward slashes.

2 Likes

Try it with single forward slashes

Just checking : Your browser and Node-red are both running on the same PC, as opposed to for example Node-red on a Raspberry Pi and browser on Windows?

You are running node-red natively on windows (ie. not running in a docker container) ?

That doesn't work too.
"Error: ENOENT: no such file or directory, open '"C:/csv/siteinfo.csv"'"

I am running node-red in a docker container.
I think that is the reason why the solutions suggested above doesn't work.
Do you have any idea on this?

yes they are running on the same PC.

The first suggestion is not to use Docker unless you have a good reason. It just makes life difficult as you have found out.

Your Docker container likely is NOT setup correctly to have access to the file you are requesting on the Windows filesystem. Here are some links that will help you set it up correctly if you choose to continue running Node-RED inside of a Docker container:

https://nodered.org/docs/getting-started/docker#managing-user-data

However, as mentioned by Colin, If you don't have a reason to run Node-RED in Docker, it may be best to run it natively on your OS instead.

A docker container runs in an isolated mode, you cannot reach your local filesystem files.
You can make volume mappings, but you will need to store you files there.

I truly believe what you are saying.
But, for my project it is a requirement to use it.
I will try to check out the link provided by @HaroldPetersInskipp for it.
Thank you :slight_smile:

I will go through the link and let you know if it works.
Thanks

If the files are generated now and often would it be troublesome to make volume mappings ?