Impossible to install the dropbox palette

I try to install the dropbox palette, but I get this error :slight_smile:

2019-08-22T19:55:20.958Z Install : node-red-node-dropbox 1.0.2

2019-08-22T21:55:20.778Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-node-dropbox@1.0.2
2019-08-22T21:57:52.469Z [err] npm
2019-08-22T21:57:52.483Z [err]  
2019-08-22T21:57:52.491Z [err] WARN
2019-08-22T21:57:52.495Z [err]  
2019-08-22T21:57:52.498Z [err] registry
2019-08-22T21:57:52.502Z [err]  Unexpected warning for Miscellaneous Warning EAI_AGAIN: request to failed, reason: getaddrinfo EAI_AGAIN
2019-08-22T21:57:52.515Z [err] npm
2019-08-22T21:57:52.518Z [err]  
2019-08-22T21:57:52.531Z [err] WARN
2019-08-22T21:57:52.541Z [err]  registry
2019-08-22T21:57:52.558Z [err]  Using stale package data from due to a request error during revalidation.
2019-08-22T22:00:05.321Z [err] npm
2019-08-22T22:00:05.329Z [err]  
2019-08-22T22:00:05.336Z [err] ERR!
2019-08-22T22:00:05.339Z [err]  
2019-08-22T22:00:05.344Z [err] code
2019-08-22T22:00:05.348Z [err]  EAI_AGAIN
2019-08-22T22:00:05.352Z [err] npm
2019-08-22T22:00:05.405Z [err]  ERR! errno EAI_AGAIN
2019-08-22T22:00:05.598Z [err] npm ERR! request to failed, reason: getaddrinfo EAI_AGAIN
2019-08-22T22:00:05.722Z [err] 
2019-08-22T22:00:05.728Z [err] npm
2019-08-22T22:00:05.732Z [err]  
2019-08-22T22:00:05.736Z [err] ERR!
2019-08-22T22:00:05.740Z [err]  A complete log of this run can be found in:
2019-08-22T22:00:05.744Z [err] npm
2019-08-22T22:00:05.749Z [err]  
2019-08-22T22:00:05.752Z [err] ERR!
2019-08-22T22:00:05.756Z [err]      /opt/plcnext/.npm/_logs/2019-08-22T22_00_05_628Z-debug.log
2019-08-22T22:00:06.011Z rc=1

Node versions :slight_smile:

22 Aug 22:13:49 - [info] Node-RED version: v0.20.5
22 Aug 22:13:49 - [info] Node.js version: v10.15.3
22 Aug 22:13:49 - [info] Linux 4.14.63-rt40-pxc arm LE

Can you help me? to fix this problem?

How are you trying to install it?

That looks like it can’t resolve the server on the internet it needs to pull the file from

Hi Paul
I tried to install via the palette and via the command line. Same result.
To be sure the web access is possible, I made a ping before. so, web access is correct

I can not understand the log, but does this mean that some parts are downloaded and some other not?

Could you try clearing your npm cache;
sudo npm cache clean --force and retrying.

well - as per the error - can you browse to from that machine ?

Hello dceejay.

sorry, but there is no browser available
on my machine. This is not a PC.

is there any command linke ping to access
check if this url answers?

dceejay via Node-RED


23/08/2019 14:16

[Node-RED Forum]
[General] Impossible to install the dropbox palette

What machine are you using to run NR on?
Does the machine have internet access?
Can you SSH into the machine?
If so you can change directories into the.node-red folder and issue the command to install it as it explains here:

Problem fixed now, with your help, regarding what you wrote
I discovered some restrictions in my router/firewall outgoing rules.
Now it works, thanks.

It seems I have the same problem. Not possible to update Dashboard palette.

Can you please tell me what changes did you do in your router ?

Thank you !

Are you getting the same message when you try to install? If not then it is not the same problem. If you get a different message then please start a new thread and give us more information.
If it is the same error then please answer the questions that were asked in previous posts.

I'm trying to update my DASHBOARD Pellett and think there is a problem with my connection to the server.
This line from the log is quite the same as the information in that thread - do you think so ?
Or should I start another thread ?

11 verbose stack FetchError: request to failed, reason: getaddrinfo EAI_AGAIN

Here is my LOG file

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/node',
1 verbose cli '/usr/bin/npm',
1 verbose cli 'install',
1 verbose cli '--no-audit',
1 verbose cli '--no-update-notifier',
1 verbose cli '--save',
1 verbose cli '--save-prefix="~"',
1 verbose cli '--production',
1 verbose cli 'node-red-dashboard@2.22.1' ]
2 info using npm@6.4.1
3 info using node@v8.16.0
4 verbose npm-session f31332ceea9ae994
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 silly fetchPackageMetaData error for node-red-dashboard@2.22.1 request to failed, reason: getaddrinfo EAI_AGAIN
8 timing stage:rollbackFailedOptional Completed in 66ms
9 timing stage:runTopLevelLifecycles Completed in 68604ms
10 verbose type system
11 verbose stack FetchError: request to failed, reason: getaddrinfo EAI_AGAIN
11 verbose stack at ClientRequest.req.on.err (/usr/lib/node_modules/npm/node_modules/node-fetch-npm/src/index.js:68:14)
11 verbose stack at emitOne (events.js:116:13)
11 verbose stack at ClientRequest.emit (events.js:211:7)
11 verbose stack at TLSSocket.socketErrorListener (_http_client.js:401:9)
11 verbose stack at emitOne (events.js:116:13)
11 verbose stack at TLSSocket.emit (events.js:211:7)
11 verbose stack at emitErrorNT (internal/streams/destroy.js:66:8)
11 verbose stack at _combinedTickCallback (internal/process/next_tick.js:139:11)
11 verbose stack at process._tickCallback (internal/process/next_tick.js:181:9)
12 verbose cwd /home/root/.node-red
13 verbose Linux 4.4.185-cip35
14 verbose argv "/usr/bin/node" "/usr/bin/npm" "install" "--no-audit" "--no-update-notifier" "--save" "--save-prefix="~"" "--production" "node-red-dashboard@2.22.1"
15 verbose node v8.16.0
16 verbose npm v6.4.1
17 error code EAI_AGAIN
18 error errno EAI_AGAIN
19 error request to failed, reason: getaddrinfo EAI_AGAIN
20 verbose exit [ 1, true ]

As was suggested in earlier posts, try browsing to the url generating the error on the machine running node-red.
Can you access the internet at other addresses ( for example).
Are you in a work environment with an IT department that prevents access to some sites?

I think I made it at last :slight_smile:
Yes there is some connection issue. I have 2 network ports and I had set both with STATIC IP address.
I just changed the configuration of my second port to DHCP so it obtains IP address automaticly from my router, and may be that helped.
Now finaly Palette update for "dashboard" passed through.

You can manage my comments as you like.
Now I need to check if the Chart on this Dashboard is more stabile. :slight_smile:

Thank you !!!

As far as I remember, the problem was coming from the Gateway and the DNS WICH wet not correctly configured