Inject: Interval stops working around evening

Hello, i tried making my own datalogger (for solar) in node red. However i ran into an issue where the inject node works fine but around 7-8pm it starts making gaps bigger and bigger every time resulting in it stopping completely. I am aware that the issue is the inject itself since i dont see anything in the debug. The interval is 1 min and i even tried using cron plus with the same result. Thanks

Thats not strictly true have you tried pressing another inject that outputs to debug? I suspect you will find there is no debug traffic at all coming to your browser because node-red or your system is being overloaded.

Do you have a dashboard with graphs on?

As two separate nodes exhibit the same issue it is more likely your system or your flows.

Have you checked the cpu on this computer when the issue appears?

Are there any loops in your flows that might be causing a major slow down?

Are there any heavy processes running?

How are you writing to file - are you reading the whole file into memory, appending data then writing whole file back?

Hello Steve, I've got another set of injects powering my dashboard at an interval of 5 seconds those work all the time. Nodered is running on my raspberry pi,aside from nodered the only thing running is VNC and the CPU usage usally doesnt reach 90%. There are no loops running neither any heavy process. I dont write to a file i use google docs for saving the data(i'm sure that it isnt a fault on their side). Thanks.

Is that debug node directly on the output of the Inject node? If not then add one on the output. Give it a name so you can be sure what you are looking at in the debug output. Also set it to output to the console so it will go into the system log.

Then stop node red and start it again in a terminal using
node-red-stop
node-red-start
and leave the terminal window open. You should see the debug output there, so you can check if it is injecting or not.

If it is not injecting then start node-red again and post the startup output here.

Hello colin, I'll try that,and then post the results. Thanks

Hello, i tried something similar to what colin said (hooked up a csv right to the inject). And it seems like the issue isnt in the inject (sorry about that) but it seems like the issue is in the modbus node since that stops working. Thanks and sorry :slight_smile: