Is it possible to run Flows while others have missing node types?

Hello,

sometimes I get the message "Flows stopped due to missing node types" when
copy-pasting flows I found online and the modules are not yet installed.

Is it an intended behaviour that all of the flows are not running if
some - but not all - are missing node types?
If yes, is there a workaround?

I tried to disable the missing nodes as well as the flows that are using them
(double-click, disable) but that does not solve it.

There is only flow file that runs. The fact that it is split over several tabs does not matter. The safest way to try new flows is to start running in a new blank flow file.

If after importing you realise that there are missing types (I think it tells you) then you can hit Ctrl+Z to undo the import provided you have not deployed

1 Like

You can still undo after deploy (just don't refresh).

Are you sure? I just tried (placed a new function node, deployed, tried to undo) and it didn't undo.

Do you mean to creating a new project?
Or tinkering with the .node-red/flows_xyz.json files?

Either. Up to you.

Works for me. Sometimes (depending on what you do it takes 2 undos) but yes, even after deploy.

Running latest node-red (and for as long back as i can remember).

^ normally I press CTRL+Z but for demo purposes i used the action bar to undo.

Oh, I see what is going on, after clicking Deploy it is necessary to click back in the main window before Ctrl-Z, at least that is what I am finding.