Listen EADDRINUSE: address already in use

Hi, I believe this error may be related with updates.
Yesterday I updated and upgraded my Debian Linux and now I have this error visible when I try to stop or restart Node-Red.
I noticed it because my application listens to port 30300 and was working for some time when it stopped responding.
What Am I missing?

How did you install node-red?
Check in the browser that node-red is running, then stop it and check in the browser that it has stopped. Then start it again in a terminal and post the full terminal output here please.

I started having problems with my Kodular App and tried to stop/start Node Red as below:
Node-red stop and node-red start and noticed this message.

Latter I understood that I was using a wrong command and I was, in fact, starting node-red over a running node-red and thus port 1880 was already in use.

So I used the right command:
node-red-stop and node-red-start
And it worked as expected.

I also found that the problem I am experiencing with Kodular results from bugs on their last upgrade.

Thanks for your time

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.