Major update to Twitter node coming

I have this same error:
Failed to update: node-red-node-twitter
Module not locally installed
Check the log for more information

I can't find where mine is installed. It is not in the path shown here.

"Manage Palette" only offers to update to V1.0.1 or disable all

I can't see how I can delete it so could do a fresh install or update it

Any thoughts please?
Thank you

Try using these commands on a command line

cd ~/.node-red
npm uninstall -g node-red-node-twitter --save

Thank you for the suggestion.
This is what I get.

pi@tcp101:~ $ npm uninstall -g node-red-node-twitter --save
npm WARN uninstall not installed in /usr/local/lib/node_modules: "node-red-node-twitter"

I edited to add the bit about changing the directory to .node-red.

I did also change the directory but got the same result.

If you
cd /usr/local/lib/node_modules

ls -altr

is there a node-red directory? If there is cd into it and repeat the ls command

Thank you

I did also find a pointer to that path somewhere else.
In my system there are only python folders in /usr/local/lib

no node_modules to be seen.

What version of node-red and nodejs are you using? (it tells you when you start node-red via a command line)

Welcome to Node-RED

19 Jul 18:34:26 - [info] Node-RED version: v0.18.6
19 Jul 18:34:26 - [info] Node.js version: v4.8.2
19 Jul 18:34:26 - [info] Linux 4.14.52-v7+ arm LE
19 Jul 18:34:27 - [info] Loading palette nodes
19 Jul 18:34:32 - [info] Dashboard version 2.9.6 started at /ui
19 Jul 18:34:34 - [info] Settings file : /home/pi/.node-red/settings.js
19 Jul 18:34:34 - [info] User directory : /home/pi/.node-red
19 Jul 18:34:34 - [warn] Projects disabled : editorTheme.projects.enabled=false
19 Jul 18:34:34 - [info] Flows file : /home/pi/.node-red/flows_tcp101.json
19 Jul 18:34:34 - [info] Server now running at
19 Jul 18:34:34 - [warn]

try the instructions listed here New Twitter node available - upgrade *required*

I have tried following those instructions.

The part that says it will identify where the node twitter files are comes back with nothing.
I am in this loop of roadblocks.

Node-red is running on a Raspberry Pi.
I have done all platform updates and installed NPM.

The Twitter node is part of the original Raspian node-red. It shows in NPM as being installed, it also shows an upgrade available but the upgrade fails and reports as above.
The only other option is to disable. There is no option to delete.

I think there are many aspects of Node-RED that are great, but it seems that when something goes wrong and is not handled by the GUI the back end of things is a rats nest.

You are still on the very old version of nodejs. If you run the update script from the docs it will update that, but also move the twitter node to a place where you can then upgrade it.

Thank you dceejay

That was a very dignified process and has solved my problem, thank you.

I thought having done apt-get update and upgrade a number of times I would have had all the current versions of things.

This process was very smooth with nice documentation and indication of what it was doing.

Much appreciated.

You’re welcome. Apt should have updated node.js ( if you are on Stretch version of Raspbian) but it wouldn’t tidy up the nodes. Which is what you needed in order to upgrade Twitter easily.

1 Like

Regarding the changes in the Twitter API, If the tweet is longer than 160 characters the twitter input node returns a truncated msg.tweet.text and msg.tweet.truncated is true.

Just a few tweets includes an extended_tweet object with the full text and entities.

Could you update the node and include the extended param to get the full tweet by default?

In the other hand, receiving your direct messages option is broken, you don't receive any DMs.

Thanks in advance

1 Like

DMs are working for me, they do take a while to come through though thanks to Twitters new API.

I'm getting Error: HTTP Error 403: Forbidden, If I change or revoke the permissions I get Error: HTTP Error 401: Unauthorized, So I don't think is a permission issue, any idea?
btw, I can send DM's and get public content.

Sounds as if you still have the Access Tokens in place that don't include the Access Direct Messages option.

On the "Keys and Access Tokens" tab, Under "Your Access Token" check the Access Level thats selected and that these are the Tokens and Secret that you have used.

The Access Token and Access Token Secret change dependant on the options selected.

Part of the power of the Twitter API and being provisioned with a developer account - is the ability to provide twitter functionality to other users who do not have developer status. Previously functionality was granted by this node to access user accounts through the central twitter developer api access. It was easy to provision use by simple Oauth.

Can we get some insight into how node-red developers can utilize this functionality and create added value for twitter users who authorize this?