Manual install module with no nodes (before worked)

Hi,

Last night I reinstalled my Pi from scretch and I manually alter the node for Bluetooth from node-red-contrib-ignoble to point to noble from abandonware . This allways worked and I have done this several times, at least a year ago. And normally I got the nodes in the palette of Node Red. But yesterday there are no new nodes visible.

What I do.

  • Clone the repository.
  • Alter package.json to look for the other source.
  • npm pack
  • go to ~/.nodered
  • npm i
    Installation is a success.
  • Restart node-red service
    -> No nodes visible.

Do I miss something? I know that node-red-ignoble is basically EOL due lack of maintenance, and should use a stable maintained one. But it is the only BLE node that can send plain text to a UUID.

Thanks in advance!

Fixed it. I've found an old backup of this node.
Don't know what and I don't care for now. Long term is that I need to create or find BLE module that communicates with BLE. This module is no longer maintained.

If the node is abandoned, consider persuading the original author to reassign it to you or fork it and then maintain your fork.

That’s what I mean to see if a different node is available. I use this one in my project to avoid rewriting code.