Manual Node Install Dietpi


I tried to manually install npm install --global node-red-contrib-blynk-iot in the /mnt/dietpi_userdata/node-red folder as the node is still in beta and there is no easy install version.

After a reboot and checking the node-modules folder and node red nothing shows up.

Anyone have an idea please?


When you start node-red in a terminal window, where does it say the flows file is?
That is the folder where you should run the install.

On this Github page where I got the npm from it doesn't actually say where it just says "If you installed Node Red globally use this command to install npm install --global node-red-contrib-blynk-iot"

And as I'm running a RPi with DietPi I followed the advice from a post here on the discourse, which states as above to install in /mnt/dietpi_userdata/node-red. which I did and there is no trace of anything having been installed.

You don't appear to have answered the question I asked.

Sorry I never start it in a terminal window, node red is one of the many software packages that DietPi's system can install and autostart's after a reboot, update etc.

In that case you need to find the node red log and look there. If you don't know where your flows file is, how are you backing it up?

Shouldn't this be node_modules? Typo?

DietPi has a backup function, or I can manually do it through FTP or NFS.

My flows file is in the node-red folder.

Yes sorry, typo

Well, as I said, if you want to manually install nodes then you must do it from that folder, and it is the node_modules folder in there that will find them. Then restart node red and refresh the browser page.

Sorry but I stated at the beginning I'm trying install a Node and I have tried to install it in the node_red folder.

The new node node-red-contrib-blynk-iot is not in the nodes_modules folder.

Screenshot 2022-12-26 at 17.28.15

There could be more than one node-red folder. When I said in my first post that you must install from the folder where the flows file is then you could just have said that you have done that.

I have just noticed that you used --global when when you installed the node. That means that it will not be in that node_modules folder, but in the global npm folder.

I see that in the readme for the node it says


This library is in beta, it is not stable yet!!

Do not use for production

I also note that it has been in that state for 18 months without any updates. Are you sure that you do want to use that node? If you do then I suggest you add an issue to the node's page on github and see if the author responds.

Yes I realise it's still in beta but it's the only one, I've added an issue to the node's page on github.

For now seeing I only need to read some measurements I'll use web hooks.

Thanks for your help

You used --global to install it which isn't a good choice for node-red node packages. If you want to install manually:

cd ~/.node-red  // or wherever you have configured your userDir to be
npm install node-red-contrib-blynk-iot

If something you want to test isn't yet published to, you can install direct from github. with npm install gablau/node-red-contrib-blynk-iot.

Node-RED uses Node.js as its underlying platform along with the standard npm package manager, Might be worth you doing some reading on how node.js and npm work.

The readme for the node explicitly says that it should be installed globally. I know that it should not be necessary, but that is what it says.

Thanks, I did in fact cd to the node-red folder, but it didn't appear after the --global install.

This is embarrassing but I just found the node in the pallet install :grimacing:

So now all is good, thanks for the help.

1 Like

If anyone finds this topic because they were looking for assistance on installing node-red-contrib-blynk-iot, or wondering whether to use it because it's marked as being a Beta release and hasn't been updated recently, then @Ianszh's topic on the Blynk community forum, and the links contained in that topic might be useful...

Also, the Blynk Legacy servers have now been decommissioned, so if you previously used the node-red-contrib-blynk-ws with the cloud servers then this now has no endpoint to connect to.
If you're still running a Blynk Legacy local server then you'll still need to continue using the old node-red-contrib-blynk-ws


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.