Microphone node does not capture audio

When I click on microphone node in the Node-Red Dashboard and speak using my Bluetooth microphone it does not seem to capture the audio. Debug nodes do not show any message payload. Since microphone did not seem to work I introduced a new inject node ( at the top) and feed into assistant to see if that path will work. When I inject string "infection level" , "news" or "How does the virus spread" I am able to hear audio response.

Also, whenever I click on Deploy , the second error messages in the debug sidebar of the Node-Red Dashboard seems to be related to the microphone node.

What version of NR dashboard have you got? You can check by opening the Manage Palette option in the top-right menu. That error is normally related to having an older version of dashboard installed.

The NR Dashboard version is v1.0.6

That sounds like the version of Node-RED itself.

I was asking about the version of the node-red-dashboard module.

Apologies. My bad.

Checked Manage palette:



I am hitting a similar issue with microphone. I have deployed node-red on IBM cloud and according to the picture below, my version of microphone is on the latest version:

The microphone does not appear on the dashboard and I am not sure what could be the reason for that. Could anyone please help me with this?

Thank You

The recommended way to install nodes on IBM Cloud is to edit your application's package.json file and not to use the palette manager.

This is because he IBM Cloud application does not have a persistent file system and any nodes you install with the palette manager have to be dynamically reinstalled whenever the app is restarted.

This is a problem for the microphone node because if it installs before the dashboard node has been reinstalled then it fails to register itself with the dashboard properly. You also risk running out of memory in your app because the npm install uses lots.

But if they are are adding to the package.json file, then they get installed into the base application image and it all works.


Thank you.
I have Lite plan. First, I tried to use tool chain and Git repo to install microphone by adding the dependencies in package.json. Since I had developed covid assistant app also I stopped it and tried the Deploy again. Although Build stage passed Deploy stage kept failing. This was the reason I used the Dashboard Manage Palette to install microphone node.

Today I tried one more time. Deploy failed again. The excerpt from the log is below:

“Done uploading
Binding service node-red-cgubq-cloudant-1588104493684-21083 to app Node RED CGUBQ in org <email> / space dev as <email>...

Starting app Node RED CGUBQ in org <email> / space dev as <email>...
Error restarting application: Server error, status code: 400, error code: 100005, message: You have exceeded your organization's memory limit: app requested more memory than available
Showing health and status for app Node RED CGUBQ-OLD-1588514825 in org <email> / space dev as <email>..

Thanks Nick,

I used the tool chain to install the node and deployed the app. Now I am able to see the microphone node display on the dashboard but I am get any response from the node on the dashboard. I have to following flow on node red:

and this is displayed on the dashboard:

I am not sure why there is an icon under button but, when I say something on the mic, I expect the message to appear on the node-red debug console. This is not happening. Would you know the reason for this?

Thank You

Hey Ramani,

I hit this issue as well. I tried various things to overcome this issue but the only way I found was to upgrade my plan to the standard version where they give you $200 credit. I have increased the memory to 512 MB and i didn't get that error anymore. Hope this helps.

Thank you

@moturivn I've had a couple of other reports of a similar issue - where the black icon shows below and it fails to capture audio. Unfortunately I haven't been able to identify the underlying cause. Can you check the browser javascript console for any errors mentioning the microphone?

@ramani Please be aware that once you upgrade your Lite account to a standard pay-as-you-go type application, you no longer get the 128Mb of free memory resource, so will start paying for that from the credit you're given. This is a very recent change that has caught a number of us out.

Hey Nick,

I just checked the console log when I click on the microphone I get the following errors:

Please let me know what you make out of this.

If there is no workaround for this issue, is there any other way I could use the microphone on the dashboard?


Thanks for sharing the log. I can see where it is hitting an error - I just cannot explain why you and a couple others are hitting it, but that I cannot reproduce.

I've just published 0.1.3 of the microphone node - will be updated on the flow library in a few minutes.
This applies a workaround that means the node should still work, however your 'max length' setting will be ignored and you'll have to click the button to stop recording.

Let me know if it works, and please share the console output again either way, whether it works or doesn't.

Hey Nick,

Your fix worked. I am able to receive the recording from the dashboard. Here are the console logs:

Is it possible to see get rid of the extra microphone icon below the button?
Its not necessary but just wondering if its possible

Thanks a lot Nick! That was a lot of help!!

I don't know where the extra icon is coming from.

Until I can figure out what is causing the underlying issue, I don't know what else I can do.

Ideally someone will be able to reproduce who is able to help debug it.

No worries. Thanks for all the help!

I've now published 0.1.4 that properly fixes the issue with the microphone node.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.