Node red microphone error

I installed microphone node from node red manage palette:

I first saw the node in the dashboard, after restart of node red the microphone node is gone, missing. I tried to uninstall it but I get the following error.
TypeError [ERR_INVALID_ARG_TYPE]: The "path" argument must be of type string. Received undefined (line:327)

how to solve this?

What version of Node-RED and node,js are you running? (you can get these from the startup log)
What device are you running on?
Have you tried any of the examples?

See examples under Node-RED editor menu of Import/Examples/node-red-node-ui-microphone.

I am using NR version 3 just released. Because of the earlier error posted above, when i try the example I get unknown error on microphone ui as shown below.
4

And my other question?

Please stop/start NR from a CLI and copy the log untill is shows [info] Started flows which comes after [info] Starting flows

i didn't see that part, i am using windows 7, on firefox.
below is the cli, but i am not sure whether this is the log part you wanted.

I also get errors when i installed other node libraries, such as arduino nodes library, could it be because of windows 7?

To quote from @TotallyInformation in this post:

If you are still using Windows 7 you are risking yourself and your information since it has been out of support for so long. If you can't upgrade to Windows 10, you might want to consider changing to a supported version of Linux.

(Taken from Win 7 - Not Suported by NodeJS - #3 by Steve-Mcl)

1 Like

It could very well be a windows thing since it mentions path as the problem.

from the above link i think they indicates that windows 7 has problem with newer version of node.js and node library installation seems to depends upon node.js irrespective of node-red, so i think this is the case.

thank you all