Move node-red to faster RPi

I started installing node-red on a raspberry pi 2B and now regret that I didn't install it on a 3B.
I know that you cannot simply put the sd card in the other machine and expect it to work.
Different processor. Is the only solution to do a backup on the 2 and a restore on the 3 or can I install node-red on the 3 and then restore the .node-red directory?
Sadly I have to use the same sd-card as this is my only 128G card and I want "some room".
The databases I will backup and restore with HeidiSQL.

Going from 2 to 3 should be ok. It’s going the other way that won’t work. Give it a go.

but the wifi does not work. I tried. in the 2 there is a usb wifi stick.
Of course I could move the stick as well..

I had installed the Raspbian with the gui so I could easily enable the onboard-WiFi.
I am used to install the command-line only version for a server like this to prevent software I don't need.
So everything works.
I tried this afternoon to run a Raspbian-light I installed on a Pi-2 on a Pi-3 but could not get the onboard
WiFi going. (I did not Google for a solution by the way).
I am glad I installed the normal Raspbian (without all the extra packages).
So problem solved.

When ever i want to flash a new SD card, I flash it (on my Mac) then before ejecting it I blank file called ssh to it and a text file called wpa_supplicant.conf to the SD card.

I prepared the wpa_supplicant.conf file on one of my Pi' by running (from the command line) wpa_passphrase [ ssid ] [ passphrase ] so if my SSID was node-red and my passphrase was 'I love Node-RED' I would enter

wpa_passphrase "node-red" "I love Node-RED"

which returns

	#psk="I love Node-RED"

and that would go into the wpa_supplicant.conf file. You can even add more than one entry to the file. I have my SSID and my daughters so if I bring something up to her house, it will connect to her SSID.

This just makes it easier to get the Pi's up and least for me it does and no need for the GUI.

1 Like

Of course a problem occurred after replacing the 2 by the 3. I use the serial port on the 40-pins connector and on the 3 the port AMA0 is connected to the blue-tooth. Sigh. And the port that they gave as a replacement is not consistent in baudratespeed, that varies with the cpu clock.
So now I must use an USB-to-serial adapter. What a mess they made of it.

solution was given in this thread: RPi-3 serial port problems

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.