MQTT - Client to Cloud MQTT

Hi,

On my Laptop I have node red running, I want t connect to oracle via MQTT. I installed mosquitto on the oracle instance.

I have opened the firewall for port 8883 and 1883. I have tested this as I connect to another server via MQTT and the messages are getting passed on.

I am not sure of how to set up the above.

On both sides the MQTT node show connected but the messages don't get passed.

Laptop
10 Aug 12:40:03 - [info] Node-RED version: v3.0.1
10 Aug 12:40:03 - [info] Node.js version: v14.17.1
10 Aug 12:40:03 - [info] Windows_NT 10.0.16299 x64 LE
10 Aug 12:40:04 - [info] Loading palette nodes

oracle
10 Aug 14:31:00 - [info] Node-RED version: v2.2.2
10 Aug 14:31:00 - [info] Node.js version: v14.19.1
10 Aug 14:31:00 - [info] Linux 5.15.0-1013-oracle arm64 LE

Look at the mosquitto log in the cloud to see what it says.

I hope those are not the real ip addresses and user/pwd. If they are then change them immediately.

Hi @ScheepersJohan , may be you need to configure MQTT mosquitto to allow connections:

"Boolean value that determines whether clients that connect without providing a username are allowed to connect. If set to false then another means of connection should be created to control authenticated client access."

mosquitto.conf

If the laptop MQTT node is showing connected then it cannot be that.

1 Like

Not really a good idea to use 1883 over the Internet. Do everyone a favour please and change to a TLS interface only. You will also need to change the user id and password after implementing TLS. Not just because you've shown it here but also because you've been broadcasting it in clear text over the Internet.

1 Like

Don't stress I will never reveal real IP or users/pwd on an site.

1 Like

Ok so I have figured out that my mistake, msg were sent as msg.quarry:"Test", it needs to be msg.payload:"Test". This is still on 1883

Now to enable port 8883 and add certificates.