MQTT-in node produces undefined

Hi there!
I came across the weird behavior of mqqt node. I made new espboard that publishes to mqtt and made new flow with mqqt-in node. This node in debug node shows "undefined". I tried various scenarios and got the same result.
However if I change topic in already existing mqqt node from other previously created flows it shows correct output.
So if I copy this mqqt node with correct output then this newly created node again gives "undefined". If I grab new mqqt node from left panel - again gives "undefined".
Tried to restart server, reloaded browser - no luck so far.
Any ideas?

  1. How do you have the debug node setup?
  2. Is the debug node connected directly to the MQTT node?
  3. Show us a screenshot of the flow and debug output

Your debug is set to watch MQTT node ONLY delivers values in msg.payload

Yes, You are right! I changed to msg.payload and now everything runs. Thanks a lot! :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.