MQTT IN node - today's dumb question

Sorry, NOT the latest NR, but close. NR 3.0.2
(I'm still running OLD versions on other machines.)

MQTT IN node.

Status quo:



Go to the newer option.


Screenshot from 2022-12-03 11-00-00

The other was CONNECTED.

Sorry, I am not having a good day just now.
I know that's no excuse, but please.

Both versions show as connected for me on 3.0.2. Are you sure you have the server details and security the same in both versions?

My pedantic side insists on mentioning that an older feature now discouraged is deprecated not depreciated

1 Like

I can't spell. Let alone read. :wink:

It is sad how bad things have become between the information in and information out side of things for me.

All I did was change that setting and re-deploy.

Nothing else.

Not a big deal, it just threw a spanner in the works for me for a while as I was testing other things.

It's the message in the node that's wrong!

OK. That's the same thing I did and it worked so I don't know what to suggest.

No problems.

Thanks though for the replies.

I'll put it down the Gremlins. :wink:

Was that the only MQTT subscription in that node-red?

What method of deploy did you use?

Sorry, I'm not getting the first part.

It was only subscribed to one topic.

I deploy changed nodes.

Add another MQTT In subscribed to something. Anything. There was recently an issue that the node would disconnect on Deploy if there was only one node subscribed to the broker.

Well, I tried and set the topic the same and this time it works.

Again: Sorry. It seems it is the typical for me and fails at initial report it didn't and now I said it, it works.

As it seems to not be happening now I shall move on.

Sorry folks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.