[MSSQL] "Eproto" error after updating nodejs and node-red

I have recently updated node-red to 1.2.7 and nodejs to 14.15.4, and while I was testing it I have seen that the sql nodes I use (node-red-contrib-mssql-plus) give me an error.

Not long ago I published if there could be problems when updating directly and I decided to try it on a Virtual Machine with linux.

I test to do the Telnet command and it works fine

However, I have run into an error and I would not know how to fix it even looking in google.
I will leave the error here and any link that I found:

maybe I should post this on github, but since I didn't find anything here, I thought about posting it here directly

Are you using the very latest version of mssql-plus? Look in the connection settings for "Trust Certificate" - is that checked? Try toggling it, then deploy.

Please let me know if this fixes your issue.

sorry for taking a long time to respond, I've been running the tests today

The result according to me, is the version of node.js

I tried the version

  • 10.15 from nodejs
  • 1.0.0 node-red
  • 0.4.4 node-red-contrib-mssql-plus

it worked

update node-red and node-red-contrib-mssql-plus to the version i use

  • 10.15 from nodejs
  • 1.2.7 node-red
  • 0.6.4 node-red-contrib-mssql-plus

it worked

update nodejs to version 14.15.4

  • 14.15.4 from nodejs
  • 1.2.7 node-red
  • 0.6.4 node-red-contrib-mssql-plus

The error appeared

I thought that it could be an error from my server or from the linux virtual machine, that's why I tried it again with windows 10 getting the same results

On the non working W10 machine, did you check and toggle "Trust Certificate" in the connection settings?

There was a recent change in underling tedious sql code that forces the default to NOT trust.

TEST 1...

can you try toggle that new setting, deploy, test, toggle back, deploy, test.


TEST 2...

Try adding --tls-min-v1.0 to the node switches.
image

(typically on windows node.red.cmd is here C:\Users\username\AppData\Roaming\npm\node-red.cmd but you can find it by entering where node-red in a cmd window).

Finally that solved my problem
I was trying to run node red with that command, when I should have put it inside node-red.cmd

Even if it is a solution, I do not think it is the most reliable to configure the command every time you want to install a new instance

image

One last question, how do I incorporate this in linux, there is no node-red.cmd in my installation

Enter which node-red in a terminal. What do you see? There is a batch/script file that launches node-red (can't check right now, someone else might pop in and provide an answer).

Long term, there may be a means of entering this in the connection settings in the MSSQL-plus node (unsure) but if I add it, are you in a position to test it & feedback?

/urs/bin/which: no node-red in (/usr/local/sbin:/usr/local/bin .......
i have installed node-red with npm in /apps/node-red. That's why I'm pretty sure about the node-red files I have
there is a node-red file but not the cmd

I can try something on the weekends, since this was due to a service that I was doing at work

I will investigate a little more to see if I can get this to start in linux
I will be attentive to new updates of the node :wink:

There wouldn't be on Linux. It'll be the node-red file. Edit it with gedit or nano or vim or whatever you use / have.

I use nano.
node-red file is very similar to red.js

however I have found that the first line of the code uses something called "shebang", the first time I see it, I am not used to linux scripts

I have seen that this does not support parameters ... as it would be --tls-min-v1.0


If one of these days I find the solution, I will leave it here written

@Steve-Mcl ,so much so that the solution is a simple click.
If I needed to connect to azure I could not, but to the local database I can

@Nxito I should have asked - I assumed you wanted to use encryption (otherwise I would have told you so check that) DOH!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.