Netbeast router URL is missing or device cannot be found

#1

Hi, I cannot make it work, once I install npm install -g --unsafe-perm node-red then Install npm install node-red-dashboard

and then install node-red
I uploaded bellow screenShot
node-red

Any hint please? thanks

0 Likes

#2

Have you read the netbeast nodes readme? It says you have to have something else running before using the nodes. https://flows.nodered.org/node/node-red-contrib-netbeast

No idea if that is related, but its something to look at.

You may need to uninstall the netbeast node module to get things working.

0 Likes

#3

thanx,
Yes, i was read neatbeast readme.

i was tried to uninstall and reinstall “node-v8.11.2-x64” but not any solution

0 Likes

#4

Before you start Node-red have you started your netbeast dashboard?

0 Likes

#5

Yes Sir,
i installed the “npm install node-red-dashboard” command (has been started netbeast dashboard url http://localhost:8000/ ) and then i will install node-red but he is not working yet.

Can you please help me .

0 Likes

#6

If you have tried starting the netbeast dashboard before starting node-red and it is still not working.

You could try uninstalling the node-red-dashboard node or the netbeast node and see if that then works.

cd into your .node-red directory and running the npm uninstall command with the name of teh node you choose to delete

0 Likes

#7

Hello ,

I was uninstalled "npm uninstall node-red-dashboadr" and npm uninstall .

I have attach the below screenshot plz find it.

but getting same issue of netbeants url issue.

i following installation guide in the url : https://nodered.org/docs/platforms/windows
uninsatll

0 Likes

#8

So the warnings it gives are just warnings .

As it isn’t a compatibility issue between the two dashboards I suggest you open an issue on the github page for the netbeast nodered node

0 Likes

#9

Hi
Step1. go to your .node-red-->package.json and remove node-red-contrib-netbeast entry and save it
image
Step2. go to the .node-red--> and remove node-red-contrib-netbeast folder completely or any other folder related to the netbeast from same location
step3. do npm audit fix
step4 node-red
you will be good!

0 Likes

#10

That is generally not advisable, unless you know what you are doing.

0 Likes