Netbeast will not run under node-red

I have installed node.js and node-red on my Windows 10 pc. I successfully created a few very basic flows and added them to the dashboard. I then decided to add Netbeast. I did the installation. After the installation, I can not load node-red any longer using the node-red command from the windows command line. I have tried using numerous schemes to uninstall both Netbeast and node red with no success. I tried running the npm uninstall command and also tried to delete the .node-red directory. nothing has worked.
I would appreciate any assistance on how to do an uninstall and a clean install of node red. I will save Netbeast for later in my experience.

Regards,
Bob

Welcome to the forum.
Please post the output you get when you try to run node red. Copy/paste the full output including the command up to the error. When pasting use the </> button at the top of the forum text entry website.

Did you start the netbeast server? I also note that the node hasn't been updated in 3 years. While it might still be OK, that's a long time considering how fast everything else is moving.

Colin, here is what appears after the node-red command is issued.

C:\Users\kn4hh>node-red
10 Oct 08:54:27 - [info]

Welcome to Node-RED
===================

10 Oct 08:54:27 - [info] Node-RED version: v1.1.3
10 Oct 08:54:27 - [info] Node.js  version: v12.19.0
10 Oct 08:54:27 - [info] Windows_NT 10.0.19041 x64 LE
10 Oct 08:54:28 - [info] Loading palette nodes
Netbeast router URL is missing or device cannot be found

C:\Users\kn4hh>

I am unable to get the Netbeast dashboard to run as I understand you need to have running before running node red.

Bob

I am not able to get Netbeast to run at all.
I would really like to get back to a clean install for node red. Nothing I have tried will completely delete node red and Netbeast.

Bob

What happens if, in a terminal, you (most important) go to your .node-red folder and run
npm remove the-netbeast-node
I don't know what the node is called, whatever it was that you installed. Post the result here if it fails. Otherwise restart node red.

Sorry for all the bandwidth. I tired going to the .node-red folder and uninstalled the netbeast node. It appeared to delete. However when I go back to the command prompt and execute node-red, it begins to load and then I still get the last line

Netbeast router URL is missing or device cannot be found

I did an uninstall of node red and deleted the user directory. I reinstalled node js, npm and node red. I get the same result. Obviously, I am missing a file or folder that is telling windows that some element of netbeast and node red is present when I do the uninstall.

Bob

You may need to do some background reading about how node.js and npm modules work. Then you will be able to understand how to remove and reset things.

To fully remove Node-RED npm -g remove node-red then delete the userDir rm -R ~/.node-red. This deletes EVERYTHING so if you want to save any flows, best to simply rename the userDir.

From your .node-red folder what do these show?
npm list node-red-contrib-netbeast
And
npm list -g node-red-contrib-netbeast

I finally found all the remnants of Netbeast in my windows 10 pc and deleted them. I now have a clean boot into node red and can get to the workspace and dashboard.
Many thanks for your patience.
Regards,

Bob

1 Like

I wonder whether you installed the node globally (using -g). If so you would have found a folder under a node-modules folder somewhere.