[new user] Blank screen upon starting node-red

Upon starting node-red, it comes out to be a blank page. Fairly new with little knowledge on OS, help please!.

pi@raspberrypi:~ $ node-red-start

Start Node-RED
 
Once Node-RED has started, point a browser at 192.168.0.102:1880
On Pi Node-RED works better with the Firefox or Chrome browser
 
Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot
 
To find more nodes and example flows - go to flows.nodered.org
 
Starting as a systemd service.
Started Node-RED graphical event wiring tool.
10 May 02:17:43 - [info]
Welcome to Node-RED
===================
10 May 02:17:43 - [info] Node-RED version: v2.2.2
10 May 02:17:43 - [info] Node.js  version: v16.14.0
10 May 02:17:43 - [info] Linux 4.9.41-v7+ arm LE
10 May 02:17:45 - [info] Loading palette nodes
10 May 02:17:49 - [info] Settings file  : /home/pi/.node-red/settings.js
10 May 02:17:49 - [info] Context store  : 'default' [module=memory]
10 May 02:17:49 - [info] User directory : /home/pi/.node-red
10 May 02:17:49 - [warn] Projects disabled : editorTheme.projects.enabled=false
10 May 02:17:49 - [warn] Flows file name not set. Generating name using hostname.
10 May 02:17:49 - [info] Flows file     : /home/pi/.node-red/flows_raspberrypi.json
10 May 02:17:49 - [warn]
---------------------------------------------------------------------
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
---------------------------------------------------------------------
10 May 02:17:49 - [info] Server now running at http://127.0.0.1:1880/
10 May 02:17:49 - [info] Starting flows
10 May 02:17:49 - [info] Started flows

Hi and welcome to node-red and the forum :slight_smile:

Can you please press F12 to open the browser dev tools and look at the console tab to see if you are getting any errors?

BTW, you need to make sure that, when pasting text or code into the forum, the text goes between the two lines of triple backticks. Yours appears to have gone a little astray.

Also, try disabling any browser extensions & reload.

Here it is! Alright sure, will take note of the pointer. Thanks :slight_smile:

Yep! I have since disabled all extensions and reloaded, but to no avail still :confused:

Urm, Chrome 60 was released 5 years ago! So I don't think that's ever going to work :face_with_raised_eyebrow:

Looks like you might be on a Pi or other Linux? If so, you need to get it updated.

I have updated it since and it is no longer showing a blank screen, thanks!

Friendly advice, try to keep your compute devices more up-to-date. There are some real nasties out there that regularly exploit out-of-date software.

2 Likes

Happy Cake Day Julian.

Haha, thanks Steve! Looks like May 18th 2018 was my first post. Of course, I joined the previous Google Group on 22nd Jan 2015 and I've been using Node-RED since around Oct/Nov 2014 I think.

1 Like

Nice! Thanks for the advice, also I have another question. I followed this Youtube Tutorial https://youtu.be/nN9SJfK0iIo?t=102 where i changed the port number of the modbus server node originally from 10502 to 502 and it has since made my Node-Red unable to start. I have since accessed the .json file and revert the change back to 10502 but it seems to still be reading at 502, any suggestions?

Welcome to Node-RED
===================
11 May 01:25:45 - [info] Node-RED version: v2.2.2
11 May 01:25:45 - [info] Node.js  version: v16.14.0
11 May 01:25:45 - [info] Linux 4.9.41-v7+ arm LE
11 May 01:25:47 - [info] Loading palette nodes
11 May 01:25:51 - [info] Settings file  : /home/pi/.node-red/settings.js
11 May 01:25:51 - [info] Context store  : 'default' [module=memory]
11 May 01:25:51 - [info] User directory : /home/pi/.node-red
11 May 01:25:51 - [warn] Projects disabled : editorTheme.projects.enabled=false
11 May 01:25:51 - [warn] Flows file name not set. Generating name using hostname.
11 May 01:25:51 - [info] Flows file     : /home/pi/.node-red/flows_raspberrypi.json
11 May 01:25:51 - [warn]
---------------------------------------------------------------------
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
---------------------------------------------------------------------
11 May 01:25:52 - [info] Server now running at http://127.0.0.1:1880/
11 May 01:25:52 - [info] Starting flows
11 May 01:25:52 - [info] Started flows
11 May 01:25:52 - [red] Uncaught Exception:
11 May 01:25:52 - [error] Error: listen EACCES: permission denied 0.0.0.0:502
    at Server.setupListenHandle [as _listen2] (node:net:1313:21)
    at listenInCluster (node:net:1378:12)
    at doListen (node:net:1516:7)
nodered.service: Main process exited, code=exited, status=1/FAILURE
nodered.service: Unit entered failed state.
nodered.service: Failed with result 'exit-code'.
nodered.service: Service hold-off time over, scheduling restart.

I changed it using the code below, hopefully it is right.

nano /home/pi/.node-red/flows_raspberrypi.json

Generally ports below 1024 need root access. There are ways to allow non-root access to low numbered ports by normal users but that is best found by google.

1 Like

start node-red in safe mode & search for 502

node-red --safe

Or best not done at all unless you really have a good reason.

Got it, thanks. Thanks to the others for the tip as well.