New Zigbee dongle

I'll second the kudos for the ElectroLama, it works great. But only when it's directly plugged in to a USB port, it wouldn't work when I used a USB extender cable as some recommend. I've since bought a powered USB hub but haven't got around to trying it.

Are you sure there is not a problem with the cable? Adding an extender cable should not make any difference. Note that if you unplug it and plug it back in again (without rebooting) then the adaptor may be given a different device address. Did you try rebooting with it connected via the cable?

I have mine on an extender and it works absolutely fine. Of course, not all USB cables are made equal so certainly try a different cable.

One thing I did note with my device was that the USB type A plug was a little loose so maybe check that it is seated correctly.

That's why I only use the by-id device name now and never the legacy tty device.

Plugged the ElectroLama into a powered USB hub on the end of a (2m) USB extender cable last night and it's been working fine. Could be that a USB3 spec cable with it's higher power capability would be better suited.

You didn't answer my question as to whether it worked on an extension cable if you rebooted.

Apparently, things have improved recently. My dongle arrived yesterday, and family permitting, it could get a trial this weekend.

I had no problems what so ever in Dezember ā€¦ to get this running on a fresh install of zigbee2mqtt (but failed with the migration)
No need for disable or difficult scripts to get the bootloader into flash mode

Since then it runs without any problems with around 40 devices

Yeah i watched that video and read about a flash method without having to solder, mine is also on its way :slight_smile:

That depends on the cable length and which USB spoec it meets. USB3 cables are rated for 900ma, whereas USB2 only 500ma. I used a USB2 extender cable that I happened to have on hand. I suspect that my issue was excessive voltage drop on the 5V supply sInce the powerered USB hub solved my problem.

Yes, I cold booted seveal times.

What is the current spec of the device?

The website and packaging say 5V @ 100mA max.

A great resource all around zigbee adapters and devices is the zigbee2mqtt project website

Some information is even better than in the original docs. For example the ikea remote 5 key button can be factory reset and paired via 4 button presses and not 10s press and hold like in the manual.

Currently 1937 devices are supported from 271 different vendors. In case you own a Zigbee device which is NOT listed here, please see How to support new devices.

Impressive collection and well maintained docs.

1 Like

@palaing if the load is only 100mA then the type of cable should make no difference.
What did you see in the zigbee2MQTT log and syslog when you used the cable?

Hi Colin,
On a cold boot a console message reported "failed to connect to the adapter" and the zigbee2mqtt program stalled. I'm using a RPi-3B, and I'm thinking that perhaps my power supply could be a little soft, it was originally used for charging a USB battery for a cell phone. A low or underrated power supply could explain why I've had this problem.

Cheers,
P

I haven't been able to find a current spec for the ElectroLama ZZH. I had a look at a TI CC2652R radio chip data sheet and couldn't find much other than 9.6ma radio transmit and 10ma flash erase current.

Certainly that could be an issue. If the PSU was intended just as a charger the voltage regulation might well be poor.