newNode - no such package available

I am using following json to set up a new npm repo and install using pallet .
"name":"Node-RED Custom catalogue",
"updated_at": "2016-08-05T18:37:50.673Z",
"modules": [

  "description": "Simply call etherium contracts from node-red, powered by Ethers.js and Etherscan",
  "keywords": [
  "types": [
  "updated_at": "2020-02-14T13:06:30.531Z",
  "id": "node-red-contrib-example-lower-case",
  "version": "1.1.1",
  "url": ""

I can see the the new node listed in pallet ,but when I try to install it ,I am getting error which says that it is trying to fetch node named newNode .

16 Feb 08:11:56 - [info] Starting flows
16 Feb 08:11:56 - [info] Started flows
16 Feb 08:12:54 - [info] Installing module: node-red-contrib-example-lower-case,
version: 1.1.1
16 Feb 08:13:18 - [warn] Installation of module node-red-contrib-example-lower-c
ase failed:
16 Feb 08:13:18 - [warn] ------------------------------------------
16 Feb 08:13:18 - [warn] npm ERR! code E404
npm ERR! 404 Not Found - GET
73/newNode - no such package available
npm ERR! 404
npm ERR! 404 'newNode@1.0.0' is not in the npm registry.
npm ERR! 404 Your package name is not valid, because
npm ERR! 404 1. name can no longer contain capital letters
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\cyjajose\AppData\Roaming\npm-cache_logs\2020-02-16T02_43_

16 Feb 08:13:18 - [warn] ------------------------------------------

What can be the reason for this faliure.

Does the error not explain it?

"name": "node-red-contrib-example-lower-case",
"version": "1.1.1",
"description": "Covert Lower To Upper",
"main": "lower-case.js",
"scripts": {
"test": "node lower-case.js"
"keywords": [
"node-red": {
"nodes": {
"lower-case": "lower-case.js"
"author": "Jose Paul",
"license": "ISC",
"dependencies": {}

This is my package.json for node-red-contrib-example-lower-case .I am getting the error on newNode ,not sure where this comes .There is no word newNode in any of the files .for this custom node.
It is searching at
73/newNode ,instead of npm ERR! 404 Not Found - GET

How have you configured npm to use your custom registry?

What do you get if you run npm install node-red-contrib-example-lower-case manually?

It tried this command ,it install with charm with --registry along with command .This looks like some problem with local npm as you suspect .I tried it in another Node-red in AWS it got installed .
Thank you so much Nick for the support ,it helped me to think in different direction. .

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.