No Debug output & Filed to load "http://localhost:1880/vendor/purify.min.js.map"

I have seen both these problems in the forum but no answer. This is a clean/new install on windows 10 exactly as in the node-red docs "getting-started/windows"

I I followed MQTT Publish and Subscribe Using Node Red by Steve Cope video tutorial (MQTT Publish and Subscribe Using Node Red - YouTube) but there is no output in the debug window.

Looked at the console in DevTools and see the message

DevTools failed to load SourceMap: Could not load content for "http://localhost:1880/vendor/purify.min.js.map": HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE.

This is because purify.min.js is not present so it cannot load it. This can be seen under sources in DevTools so I guess that node-red install package is not installing this. But will this account for no output in the debug window

Note The broker is on Raspberry Pi and I have tested this and it works both using the Pi to publish and subscribe and to an ESP8266 to turn on and off an LED.

Any thoughts ideas on how to solve this or I will have to ditch Node-Red unless I have more success on my Mac.

Welcome to the forum @sjgc

You can ignore that, it is not an issue.

Tell us more about the actual problem you are seeing. Where are you seeing nothing in the debug node? If you are subscribing to an MQTT topic then install MQTT Explorer which many consider an indispensable tool if you are using MQTT. Then you can check that there is actually something to subscribe to on the topic.

OK on ignoring that issue. What I am seeing is that when I run the example as per the video tutorial when I inject the message I get the pop up "Successfully injected sensor 1" but the debug panel on the right remains empty.
Flow

In this example node-red is the publisher and the subscriber hence the debug node (or that is what I assume) and the video shows.

what topic are you publishing to (attach a debug to output of inject "sensor1")?

inject payload
MQTT in node

there is your issue.

You publish to sensor/sensor1 but you subscribe to sensors/#

Are you new to MQTT or was that a typo?

Many thanks it works now and new'ish i.e. very much a novice and since I copied the video tutorial I assumed that the # was acting like a wild card. However I have also just noticed the extra s in sensors/#

I suggest you read through this excellent tutorial, it will give an excellent grounding in MQTT MQTT Essentials - All Core Concepts explained

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.