Node info on hover is not showing for custom node which is having type "subflow"

Hello,

when i hover on my custom node then node info is not showing for custom node which is having type "subflow". instead it is showing message "no information available".

Can u please help out here?
@knolleary

Thanks

Hi @dhpatel177

I assume you mean when you hover over it in the palette, the tooltip that appears shows 'no information available' ?

If so, that was fixed in 1.2.8.

In future, there's no need to tag me in your threads. There's a whole community of users who can help here.

ok thanks and can u please guide me how can i upgrade version of my current project?

If you describe how you installed Node-RED originally, I'm sure we'll be able to point you in the right direction.

I had clone the project from github then i had run few commoands like 'npm install', 'npm install -g --unsafe-perm node-red'.

following is download link:

What version of Node-RED do you currently have?
And what version of Node.js are you using?

You can probably just rerun npm install -g --unsafe-perm node-red to get the latest version.

And if i want to upgrade my docker image node red version then what should i need to do?

Follow the instructions in the docs.

https://nodered.org/docs/getting-started/docker#updating

as i run above command but still when i run my project it shows older version

How are you running Node-RED?

What does npm list -g node-red show?

npm run start

npm run start

I thought you said you ran npm install -g node-red ...

Oh I see you edited your earlier post. You've cloned the node-red git repository? Why did you do that? Is there a reason to run the code from git rather than use the stable releases?

i was new to node red and i had now build up my solution using that git code.

Does this mean you've customised the node-red code? Or did you just do a git clone to get the code?

Assuming you've not modified the node-red code base, then you have two choices:

  1. run git pull to get the latest code, then run git checkout 1.2.9 to make sure you're on the latest stable release before rebuilding the code.

  2. Don't clone from git and use the npm installed version you have.

To use the npm installed version, as you have already installed it as a global module (the -g flag) you should find you have the node-red command available in your terminal. Use that instead of npm run.

yes i have downloaded the zip and customized that as per my requirenment.

It would have really saved a lot of time if you had explained that at the start.

You now say you downloaded the zip - I thought you cloned the repository?

If you have modified the code base then you must have had some plan for how to update the code to pickup fixes etc from the base project?

You'll have to pull down the latest code, either download the latest zip, or pull the changes from the git repository and merge them into whatever changes you've made. That isn't something we can help you do.

But this will work right for my docker image...as i have also another solution for which i have created docker image.

I have found the solution for this.

Thanks.