Node PID enable/disable not working

#1

Hi,

I am not getting the PID in disable mode. Am I doing something wrong?

[{"id":"6deef0a.ca0fa1","type":"function","z":"d71f1b7b.004ad8","name":"","func":"msg = {payload:1}\nmsg.enable = 1;\nmsg.topic = \"enable\"\n\nreturn msg;","outputs":1,"noerr":0,"x":314,"y":182,"wires":[["37d2fe8f.ccfba2"]]}]

Frank

#2

Which pid node are you using? node-red-xxxxx-xxxxx

#3

Hi Colin,

I am using this one:

node-red-contrib-pid

Frank

#4

That function node should work, and does work for me. I notice though that the status display does not change until the next time it receives a process sample, so if you are not also sending it data then you won't know that it has worked. Feed an inject node direct into the pid node to give it something to do and your function node should work. If not then post a mini-flow with injects and the function and pid node exhibiting the problem.

#5

Ah Colin,

You are right again. Disable is displayed when other feed is going in.

Thanks.
Frank

#6

My reflow oven stayed on this afternoon burning my PCB so thought the PID was the issue. I didn't set all variables to default when off. Grrr. But the graph looks great now.

1 Like
#7

I have submitted an issue against the node, next time I am doing anything to it I will sort it. https://github.com/colinl/node-red-contrib-pid/issues/8

#8

Thanks highly appreciated. It helps hobby programmers like me to visualize their mistakes. I can see nothing is turning on my oven because some nodes putting out data after presumed stopped. Buffering or temp updates messing with my output :grin: