🎉 Node-RED 2.0.0-beta.2 released

:tada: The next beta release of Node-RED 2.0.0 is now available.

This should be the last beta release ahead of the final release later this month.

The Change Log has the full list of changes in this release, but here are the highlights.

Note: if any issues are reported against the beta, we'll update this post to list them here. If you hit a problem, please do check back here before adding a comment.

Known Issues

  • none

Changes

Please read the first beta release note for major changes. The following items are the new items for this beta release.

Just as a reminder, Node-RED 2.0 does not support anything earlier than Node.js 12.

  • HTTP Request support for HTTP Proxies has been fixed
  • Debug sidebar supports Map/Set type properties
  • File In: Add option for file-in node to include all properties when sending msg per line (default off)
  • Exec node: add windowsHide option to hide console window under Windows
  • Various fixes for the monaco editor component

Node-RED Debugger 1.1.0

A updated version of the Node-RED Debugger has also been published - it requires this beta to run.

  • Adds option to pause individual nodes rather than the whole flow
  • Handles large message queues more efficiently - this will hopefully resolve the lock-up some users had reported when resuming flows.

See node-red-debugger - npm for more information

Node-RED Linter - nrlint - 1.0.0

The first version of the Node-RED Lint tool has also been published. It is still a work in progress, but this initial version is ready to get more feedback from the community. I'll write a separate post about it later.

See nrlint - npm for more information

Installing the beta

If you want to try out the beta, you will need specify node-red@next when you use npm to update. Without the @next you'll still get 1.x

So on a Pi you'd do:

sudo npm install -g --unsafe-perm node-red@next

Reporting problems

If you hit any problems, please report them either as a reply on this topic, or in the #core-dev slack channel. Please do not post new topics to the forum regarding the beta as that could confuse users who are not using the beta.

Outstanding work

This is nothing major outstanding at this point, aside from a couple translation updates.

We hope to release Node-RED 2.0 later this month.

18 Likes

Bildschirmfoto 2021-07-02 um 16.11.55

Thats promising :smiley:

Thanx gentlemen for this outstanding tool.

Any idea why the latest docker beta version is tagged "v2.0.0-beta.2" rather than just "beta" or "v2.0.0-beta" for nodered/node-red-dev?
It messes with my auto update for the docker image on my test server....

Because we have had to switch to GitHub actions from Travis and we haven’t got the tagging quite right yet.

ok Dave, thanks for the info - and the great work on V2!

Sorry about this but.....
Reloaded a Pi 4 with the new PI OS image and tried to install the beta 2. After the Pi complained about npm got that installed and apparently the node red install failed. I went to enter the command sudo systemctl enable nodered.service and it complains that
failed to enable unit: Unit file nodered.service does not exsist.
So...... there I am
[EDIT]
This isn't a particularly important Pi and it is a holiday weekend so I am not expecting any quick replies and I certainly won't be sleeping on the keyboard so if it takes a while for me to answer please be patient.

Ok, so I got bored and reimaged the Pi, installed v1.3.5 first then ran the beta script and it worked.

The first time round, how were you installing? Did you run the beta script?

To install the beta on a fresh SD card, run the usual install script but with --nodered-version="next" parameter - ie

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered) --nodered-version="next" --node14
1 Like

I did run the beta script and I suspect I was missing a nodejs piece although @dceejay could probably tell you exactly. Everything does seem to be working fine now.

After updating (from 1.3.5) if I open a function node (an old one that has not been modified for a while) and click Done without changing anything then the Deploy button is enabled, and if I deploy I see that it has added to the function

        "initialize": "",
        "finalize": "",
        "libs": [],

I don't think that used to happen with 1.3.5 though I cannot be certain of that. I understand what those are for and that there is no real change, the only issue is that it wants to deploy (and the changes will appear in my git history even though there is no functional change).

I just published the first BETA version of the midnight-red theme with initial compatibility to Node-RED 2.0.

npm install @node-red-contrib-themes/midnight-red@next

If you find any issues, please report them on the theme's GitHub repository.

3 Likes

Woah .. so exciting! Playing with debugger RIGHT NOW! :smiley: Can't wait for the conditions feature. Also, the Monaco Editor is very cool!

Awesome work!

Genius guys. This is a truly amazing product!

Question for Nick.
If you have the debugger installed, and you want to upgrade, how do you query the system to find out what debugger version you installed to see if it is current after upgrade? It's not available in the palette manager and It does not tell you in Node-RED... so?

Hi @hp_apcc

for now, plugins have to be managed on the command-line. They do not show up in the palette manager.

The palette manager needs a bit of an overhaul to get plugins to fit in nicely. That isn't going to happen for 2.0.

@knolleary ,
I was also looking at the listing in the terminal. In my case it would be the log file. There should also be a reference to it there if installed? That is only a suggestion. It may or may not be consistent with your system definition to have it pop up in the list of dependencies like Node.

Working well for me, thanks @mbonani

1 Like

The third BETA of the midnight-red theme is out. If you are testing it, please upgrade.

npm install @node-red-contrib-themes/midnight-red@next

If you find any issues, please report them on the theme's GitHub repository .

P.S. Thanks, @Colin for reporting the issue with the configuration nodes.

Looking at using User Properties with MQTT 5 in NR 2.0.0-beta.2 I don't seem to be able to specify the use of a msg property for the properties (gross overloading of the word in that sentence!). In the dropdown for User Properties I only see JSON type. I can't actually guarantee that this was available in the previous NR version as I don't have one to test, but I understood it should be possible.
image