🎉 Node-RED 3.0.0-beta.1 released

What connections?

What browser?

The (current) mouse & modifier keys for junctions are as follows...

  • To Splice junctions into 1 or more wires...
    • In whitespace: SHIFT KEY (hold), RIGHT MOUSE BUTTON (hold), DRAW slice line over wires.
  • To wire from a junction:
    • On Junction: CTRL KEY (hold), LEFT MOUSE CLICK (no hold), DRAW wire to other nodes input.
  • To move a junction:
    • On Junction: LEFT MOUSE BUTTON (hold), MOVE mouse

Hi @hp_apcc

Thanks for putting together a demo flow that demonstrates your issue.

Unfortunately I cannot recreate this on my development system.

Can you list your versions please...

  • nodejs V???
  • OS name? OS version?

Thanks.

@Steve-Mcl
Sorry for not enough info on the last post. It's about new features on 3.0.0 beta 1. When you Shift+mounse drag across the connectors to put in a new junction. I follow the directions and I cannot get the wires to highlight or do any such to insert a new "Junction" to mend the wires into that point. I tried and nothing is working . Linux Mint 20 and with the prior information i posted for the CRASH! bug I found.

@Steve-Mcl ,
The instructions:
o Splice junctions into 1 or more wires...

  • In whitespace: SHIFT KEY (hold), RIGHT MOUSE BUTTON (hold), DRAW slice line over wires.

Holding down the Shift Key, The instant I "Right-Click" the browser menu (Firefox) shows a menu
-Save as Page
-Save Page to Pocket
-Select All
-Take Screenshot
-View Page Source
-Inspect Accessability Properties
-Inspect (Q)

Not that I can see.

I asked for ...

You are holding CTRL KEY and using the RIGHT mouse button yes?

What browser / version are you using?
Have you tried another browser?

Firefox browser

Ok, I think you can see this ???

Firefox browser for Linux Mint-001 - 1.0 Version 100.0

Yes. And my apologies, I did not scroll back far enough (where you originally posted the startup).

So, I suspect since this doesnt happen for me on nodejs v16, that it is related to nodejs v18

Is there a particular reason you are running nodejs 18?

What version?

Well, I can go back with NVM. I installed the latest version and I did specify 16. Alas, when I updated and switched to 16 I did not get 16...I think I made this mistake as when I installed NVM, I must have selected the latest version in the command line.

OK just tried by running Node 16.15.0 Same results with Firefox browser with the "Right-Click" issue. I need to install other browsers on my Linux machine. The default is Firefox. I use that primarily so I did not install Chrom(e, or ium).

I'm checking the item of TCP nodes crashing Node-RED. Exactly the same results. If I move a node and Deploy in "Full Deploy". It pops up in the browser "Lost connection to server, reconnecting..." and Node-RED command terminal has returned to the prompt. Similar results on program termination.

  • [info] Stopping flows
  • [info] [tcp in:da552e190d95fb24] stopped listening on port
  • [red] Uncaught Exception:
  • [error] Error: read ECONNRESET
    at TCP.onStreamRead (node:internal/stream_base_commons:217:20)

nvm is not really recommended - there are a ton of posts on the forum around issues with n and nvm

Potentially, you may not actually be running the version of node that you think (does the node-red log say v16 when it starts?).

Are you using nvm for a specific reason? If not, the general recommendation around here is "dont use n or nvm"

@Steve-Mcl,
Yes, That's what it says when I run "node-red" at command prompt.

Nodejs has an installer for Windows (work). I used nvm to update as I have not committed to doing nodejs install without an "installer" on this Linux system. I'm OK, but not that good at installing using the binary files and make mistakes. I just needed to get it going and took this method. it has behaved OK as far as I can tell. I have not been updated on issues with NVM, I did not know it could be a problem.

It's a Firefox issue. See Shift-RightClick-Drag doesn't work on Firefox (v3 beta) · Issue #3582 · node-red/node-red · GitHub

Google installed and it works fine. Now on to other issues... Inject nodes going to the MQTT Out node. I added the junction. Then edited it to combine them into one. I deleted the wire from the MQTT out node. Then pulled a wire from the MQTT Out node to the junction. It looks like it should work. It does NOT.

Refresh the page and the wire pulled from the MQTT Out is GONE.

Hi. Thanks for letting us know.

This one has already been reported (see earlier posts) & is fixed in master (beta 2 coming soon)

I actually looked for it. It's all good. I did not know if this exact thing was covered. it creates a kind of mess of your "wires". You have to go back and re-route them to actually consolodate them. You need to be able to place these "Dot Junction Nodes" in like any other entitiy. Having to do hand and finger stretches (laptop track-pad) to acomplish adding something is not ... the best.

I thought I had it and my flow stopped working. Refresh, Oh No connection there!

I deployed it taking the default of "Full Deploy" and it crashed on me. (I'm pretty sure that it's the TCP nodes. The note being in the console regarding the TCP node).