🎉 Node-RED 3.1.0-beta.2 released

@Steve-Mcl Yes - in FireFox and Chrome - it does seem like it only works the first time for any one node until you refresh then it will again only work once - noter a deploy doesn't change it only the page refresh does, And as I said, in Safari, some of the nodes never seem to work while others do.

On a Mac, ctrl-cmd-f triggers the search instead of going full screen.

And ctrl-click on the workspace brings up the context menu on top of the quick-add dialog.

1 Like

The JSONata Expression Editor test is having problems

Example message

    "topic": "alexa/Oregon Sensor 01/Temperature/Update"

Error message

Invalid example JSON message:
  SyntaxError: Expected double-quoted property name in JSON at position 60

What version of macOS are you running? For me on Ventura ctrl-cmd-f takes me to full screen while on Mojave the first time I do ctrl-cmd-f it brings up the search panel and it I do it again, it goes full screen

I'm on Ventura, and I see this same behavior.

Similar errors in Chrome on Windows.

Seems that the expression is not re-evaluated unless there is a syntax error in the Example message part

  • Search button in palette popover only works once - now fixed in git
  • JSONata Expression tester - now fixed in git

Is anyone else seeing problems with link call nodes? After the upgrade some(all?) of my link call nodes are showing the red triangle. I haven't had time to work out why yet.

I saw a problem with link calls too.
Think it went away after opening the node config for each one.

Yes, you are right. After the upgrade, existing link call nodes show the error. Opening the node and clicking Done removes the error and the Deploy button is enabled.

I just learned that Apple changed the global keyboard shortcut for "Enter Full Screen" to fn-f in Monterey.

It partially works on Chrome. It goes full screen and then shows the search dialog.

On Safari, it brings up the search. It goes full screen if I hit fn-f a second time.

I was just looking at the new help button and IMHO the little icon button at the bottom is quite useless. If you don't know it's there it's really hard to see. I don't see it at all unless I go looking for it. The value of the "HELP" button at the top is that it's in the field of view of a relatively new user that is a bit lost and directs them to "hey, maybe this is a good moment to read the help text for this node". I don't think the button at the bottom does that. Just my 2 cents...

1 Like

Could I re-raise my request from the last beta to have a "remove and reconnect" in the right-context menu please


Suspect this isn't a 3.1 issue but just spotted anyway.

In the JSONata editor:

Says that msg is referenced in the JSONata code but it most certainly isn't (the bits you can't see are the same pattern as what you can see).

This is in a change node

Presumably because the text msg appears in a comment.

Oh! Found one thing, then found another! This one I think IS v3.1 related.

Trying to add a title to a group and it would not process the "Done" button. Checked the console and saw this:

This is the flow

The inner group headings still edit OK, it is just this outer heading that will not update. I tried just updating one of the colours and had the same error.

Strangely, I can edit the heading on another compound group and it works fine. But it had been created before I upgraded to the beta.

PS: Full flow is available here: uibuilder dynamic SVG example - no framework needed (flow) - Node-RED (nodered.org)

Not sure if is just me; when inserting a junction it appears at seemingly random locations, certainly NOT under the cursor.

Correct. This has been the behaviour ever since JSONata was introduced. It is doing simple regex checking to see if msg is mentioned, rather than a full syntactically parse.

Do you mean "offset by a few pixels" or entirely different flow tabs/locations etc? A screenshot would be helpful

Same flow tab, but more than a few pixels

That looks like you have zoomed out? Is that correct? Exactly what method of adding a junction node are you using?