Node-red-admin wont install

#1

Hi, long time lurker, first time poster.

I tinker with many rpi 0 w's running raspbian, a while ago on I set up node-red-admin on Jessie, the install went smoothly, now I just get this every time:

root@squid:/home/pi/.node-red# sudo npm install -g node-red-admin

npm WARN deprecated bcrypt@0.8.7: bcrypt < v2.0.0 is susceptible to bcrypt wrap-around bug. Upgrade to bcrypt >= v2.0.0 for improved support for newer bcrypt hashes

npm WARN deprecated node-uuid@1.4.8: Use uuid module instead

npm WARN deprecated hoek@2.16.3: The major version is no longer supported. Please update to 4.x or newer

/usr/bin/node-red-admin -> /usr/lib/node_modules/node-red-admin/node-red-admin.js

> bcrypt@0.8.7 install /usr/lib/node_modules/node-red-admin/node_modules/bcrypt

> node-gyp rebuild

gyp WARN EACCES user "root" does not have permission to access the dev dir "/root/.node-gyp/8.11.1"

gyp WARN EACCES attempting to reinstall using temporary dev dir "/usr/lib/node_modules/node-red-admin/node_modules/bcrypt/.node-gyp"

gyp WARN install got an error, rolling back install

gyp WARN install got an error, rolling back install

gyp ERR! configure error

gyp ERR! stack Error: EACCES: permission denied, mkdir '/usr/lib/node_modules/node-red-admin/node_modules/bcrypt/.node-gyp'

gyp ERR! System Linux 4.14.52+

gyp ERR! command "/usr/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"

gyp ERR! cwd /usr/lib/node_modules/node-red-admin/node_modules/bcrypt

gyp ERR! node -v v8.11.1

gyp ERR! node-gyp -v v3.7.0

gyp ERR! not ok

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bcrypt@0.8.7 (node_modules/node-red-admin/node_modules/bcrypt):

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bcrypt@0.8.7 install: node-gyp rebuild

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

Any recommendations?

0 Likes

#2

Recomndations...here you go

  1. don’t run as root! Run as pi
  2. are you meaning to use ‘node-red-contrib-admin’?
  3. if you are trying to install node-RED! Use the script descripbe in the documentation
0 Likes

#3

This is the sequence I use to install Node-Red .. using the raspbian image

$ sudo apt -y update
$ sudo apt -y upgrade
$ sudo raspi-config
-- config hostname
-- config timezone
-- enable ssh

$ sudo shutdown -r now

==>login via ssh

==>install npm &amp; n

$ sudo apt -y install npm
$ sudo npm install -g n
$ sudo n stable
$ sudo apt-get install git

==> install node-red

$ bash &lt;(curl -sL https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered)

$ cd ~/.node-red
$ npm rebuild

==> Autostart on boot

$ sudo wget https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/nodered.service -O /lib/systemd/system/nodered.service

$ sudo systemctl daemon-reload
$ sudo systemctl enable nodered.service
$ sudo shutdown -r now

==> install samba

$ sudo apt install samba samba-common-bin winbind
$ sudo mkdir -m 1777 /share
$ sudo nano /etc/samba/smb.conf

==> check workgroup = WORKGROUP

[home]
Comment = Pi shared folder
Path = /home/pi
browseable = yes
writeable = Yes
only guest = no
create mask = 0777
directory mask = 0777
Public = yes
Guest ok = yes

[nodes]
Comment = Pi shared folder
Path = /home/pi/.node-red
Browseable = yes
Writeable = Yes
only guest = no
create mask = 0777
directory mask = 0777
Public = yes
Guest ok = yes

$ sudo smbpasswd -a pi
$ sudo /etc/init.d/samba restart

==> install webmin

$ sudo apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python

$ wget http://prdownloads.sourceforge.net/webadmin/webmin_1.890_all.deb
$ sudo dpkg --install webmin_1.890_all.deb
0 Likes

#4

Wow speedy response, thanks

  1. documentation recommend run as root,

2.No I haven't tried node-red-contrib-admin, is that the way people in the know do it? will check it out after I try xx_nexus_xx method

  1. Yes I always use that script
0 Likes

#5

Thanks, will have to try that when I get home, having internet issues here at work

0 Likes

#6

They are WARN not errors so not a problem. Carry on.

(Though we haven't really used node-red-admin for ages - most of what it did can now be done via the UI so you may not need it - unless you have a specific need for it)

0 Likes

#7

Tried to ignore, wont give me a hashed passwd without it (node-red-admin hash-pw)

0 Likes

#8

ah yes - :slight_smile: but you can still ignore he warnings - it should still work

0 Likes

#9

Holy crap, you are right, it works!! I was sure i tested it before and it failed, I have been stuck on this for an embarrassing long time!! Thanks to all of you, I should have asked much earlier

0 Likes

#10

Didn't follow all your steps because want to keep it as minimal as possible, turns out it works despite errors, but I checked out webmin, looks great. Thanks for that and sharing your sequence

0 Likes