Node-Red and Cloudflare Dashboard Issue

Hi everyone.

I have Home Assistant OS installed on a mini PC.

Everything was working perfectly, and I could access the Node-red dashboard without problems.
But a few weeks ago I created my own domain and configured access to my Home Assistant through cloudflare, so far so good, I can access from outside and inside my Wifi to Home Assistant.

But now I can't access the node-red dashboard. When I try to access with https://mydomain.com/endpoint/ui, I get the error 404: Not Found.
I have also tried https://192.168.0.15:1880/endpoint/ui , but it gives me the error ERR_SSL_PROTOCOL_ERROR.

In the router I have redirected the external ports
443 and 80 to the IP of my MiniPC to port 8123, both UDP and TCP.

Do I have to open any other ports?

Any ideas?, what am I missing?, what am I doing wrong?...

Thanks in advance and greetings

You need to understand a bit more about how web services work I'm afraid. You seem to have opened Home Assistant to the Internet but not Node-RED which works on a different IP PORT.

You also can't access the internal IP address from the Internet of course - that would be a total security disaster.

And then, I do hope that you have put a login onto at least the Node-RED editor before you go exposing it to the Internet!

You should note however, that my feedback is based on how a "normal" system would work. I've no idea what odd things Home Assistant does. It might be different. But most people on this forum don't use Home Assistant and I have to say that HA raises more than its fair share of issues that we see on the forum. So you may be better off asking for help on the HA forum anyway.

Bottom line is this though. Don't expose things to the Internet unless you know at least a bit about what you are doing and about Internet security and networking. If you don't have that knowledge, you would be much better off using the free tier of CloudFlare's Zero Trust service which provides useful answers to these issues.

Have you tried https://mydomain.com:1880/endpoint/ui ?

Yes, but it gives me the error: ERR_CONNECTION_TIMED_OUT
Thanks for your interest.