Cannot open node-red-dashboard after migration from pi3 to pi4: 404 not found

after migration from pi3 to pi4 everything works fine but the dashboard button in the editor opens a new tab in the chrome or safari browser and shows with response 404: not found. So no dashboard is shown.

For a test, I deleted flows.json to get an empty editor, then created a ui button, but same result: 404

Any idea?

Bildschirmfoto 2023-09-14 um 17.10.49

Well, for starters, you seem to be running Home Assistant so not sure if that is having an impact. You've not shared the Node-RED startup log so we can't see all your settings. But the URL you shared has an extra level in it, /endpoint/ Not clear if that comes from Node-RED's settings or HA.

Thank you, and I have further informations:

The logentry shows an appended message: ignored due to local copy

On another production system this message is not in the log. Maybe that's there is the problem with a local copy of somewhat?

On that (identical) production system clicking the dashboard icon opens a tab with this URL:!/0?socketid=cFazA-wUDLv9ROIJAAAB and showing the dashboard.

The 404 not found message obviously occurs when NR tries to build the rest of the URL following /endpoint/ui/.....

Thanks for help!

No, I don't think that's right. Everything after the /ui is not real. You can see that on a working system by looking at the network tab of your browser's dev tools.


The /#!/0 is generated in the browser internally by AngularJS's front-end router.

So check the network tab and see whether ui/ is loading - I don't believe it is.

I activated the developer tools in chrome browser and saw this:

Maybe I have to look at another place (can you give me a hint?)

Now I tried to append the /#!/0 manually to the url in the browser!/0
and then it works!! So I guess that the dashboard button in the NR editor should send the complete URL!?

There you are using port 1880, the one that failed showed a different port.

That is interesting!! It runs with port 1880 and

So what's the reason for calling port 8123 which is Homeassistant? And how can I change that?

What port do you use for access to the editor?

I use NR is embedded in Homeassistant frame.

Same on my working reference system (different IP)

I'm afraid that is a Home Assistant question.

The Node-RED question is whether or not the Editor shows port 8123 in a previous version and if not, what has changed? Can you check that?

I tried to find out, but the only thing I found is the lolentry concerning this ignored message:

Any idea what that means?

Well, you said the link worked with previous versions - do you have a previous version to try?

Afraid not but I'm not a Dashboard expert.

I have exactly the same problem. I am using node-red v3.1 on Home Assistant HASSOS. Everything is the latest version. When I try to access the node-red dashboard, running under Home Assistant the URL is Whereas if I type in the dashboard is accessed correctly. This behavior has been the same for a few HA and NR upgrades. I suspect it is a HA issue rather than node-red since Home Assistant is targeting the wrong IP address, the /endpoint/ui is correct. In Home Assistant port 8123 is the base address for Home Assistant. Unfortunately I do not know how to change the dashboard address in HA, assuming it is a HA issue

@dceejay do you have any memory a code change around how the dashboard link is generated? (perhaps within the last few months?)

Does anyone know where in the Node-RED code that link is generated? Seems to be a bit of a sticking point in the new Dashboard too.

Fairly certain it will be computed in the dashboard sidebar code Julian. Dont have a link (but should not be too hard to locate)

it's in ui_base.html - line 1211 - last touched in 2017...

1 Like

Hmmm, curious and curiouser

Suggests that something may have changed in HA rather than Node-RED. Since it is clearly picking up an HA port not the node-red port.

Now I need to find the equivalent in Dash 2 so it can be fixed. :slight_smile:

Below you will find my nodered configuration in home assistant. port 1880 is redirected to 80. This works for the editor, but not for the dashboard button.