Dashboard url in the node dashboard widget no longer working

I bookmarked the dashboard so I can still get to it, but the dashboard widget in Node Red is pointing to the URL without the socket ID on the end, and when I navigate there by clicking the link I get an http 404 (not found error).

Now, as I said, I have a workaround, but I'm not sure how long the bookmarked page will work...

Is there some way to fix this, or do I need to back up my flows and reinstall?

PS, running node red addon to home assistant, latest/greatest for both, and dashboard


Why wouldnt it work?
The only reason i can think of is if you are accessing the Dashboard from another system from where Node-red is installed and the ip of the NR server changes.

The way you access the Dashboard is

  1. if its with a browser on the same system as node-red :
  2. another system on same network http://<node-red-server-ip>:1880/ui

no need to bookmark the socket part

1 Like



So I'm not really typing or configuring in a url when it doesn't work, I'm clicking on the widget supplied by node red dashboard, and I get a 404 (see above). This is new behaviour and why I think my install
of node red dashboard maybe has an issue - happened after a restart.

homeassistant .. sorry missed that part. i dont know anything about it
obviously there something wrong with the button link
in the url it says port 8123 ?
if you try http://<yourhomeassistantip>:1880/endpoint/ui/ ??
does that work ?

1 Like


It was the port, for some reason it's using home assistant port (8123).

Fixing the port to 1880 worked!

Now, just gotta figure out what's the deal with the widget, but I can live with it. Maybe next update will fix it...


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.