Node-Red "Connection Lost"


I have a "Lost Connection" problem on all my browsers and on various devices (Phone, PC and tablet).
I tried to empty the caches ==> problem still exists.
I reinstalled my RPI 3B several times ==> always the same problem

Help, I'm getting discouraged!

Thank you

Start Log :

5 Jun 18:56:06 - [info] Node-RED version: v1.0.6
5 Jun 18:56:06 - [info] Node.js version: v12.17.0
5 Jun 18:56:06 - [info] Linux 4.19.118-v7+ arm LE
5 Jun 18:56:07 - [info] Loading palette nodes
5 Jun 18:56:11 - [info] Dashboard version 2.22.1 started at /ui
5 Jun 18:56:11 - [info] Settings file : /home/pi/.node-red/settings.js
5 Jun 18:56:11 - [info] Context store : 'default' [module=memory]
5 Jun 18:56:11 - [info] User directory : /home/pi/.node-red
5 Jun 18:56:11 - [warn] Projects disabled : editorTheme.projects.enabled=false
5 Jun 18:56:11 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
5 Jun 18:56:11 - [warn]
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
5 Jun 18:56:11 - [info] Starting flows
5 Jun 18:56:11 - [info] Started flows
5 Jun 18:56:11 - [info] Server now running at

Welcome to the forum!
Everything looks fine with your installation! Node red is running. You have to put the IP of your Pi into a browser that is not on the Pi, NOT
https://[ip address of the pi running node red]:1880/

Further to what Garry has said above... to find your Pi's IP address, enter ifconfig in a terminal and you should be able to find your IP address towards the bottom of the printout. Something like 192.168.1.??

Hello Ghayne and Paul-Reed,

I connect well with my @IP in 192 and not in 127

For Information, I have activated the password to connect to Node-Red and I installed mosquitto broker

Great! there is no turning back now :wink:

Does that mean I have to redo a test without activating the password and MQTT?

A test? what test...

I assumed @Safety147 is having the intermittent "disconnected" notifications on the editor. That is often caused by Node-RED crashing and restarting all the time? By the look of the log it doesn't seem so though...

Not a test, but reinstalling Raspbian without the MQTT and password activation

Yes, that's my problem. The logs don't report any problems. I will try a new installation of Raspbian without putting a password and without MQTT.

I don't think they could be the issue here. Do you have a firewall in between that could somehow be causing some issues? Or is the Raspberry on wifi, and if it is, is the connection stable?

Have you read this thread which I believe is about a similar issue Node-red connection lost in google chrome? Perhaps suggestions there could be of help.

No, I didn't install a firewall or antivirus for RPI. I don't have a proxy server either.

Yes, I have seen this post but not having an antivirus it does not apply to me.
The problem is on all my web browsers: Safari, Edge Chromium, Chrome and Firefox :frowning:
Could the problem be the flows I created on Node-Red?

It is possible if they are doing heavy processing, to cause the update back to the browser to be delayed.

Do you have any loops or heavy computation going on in your flows? Working with large images perhaps? Or is the node-red device cpu usage very high?

I'm reading temperature readings on three probes:
1 DHT22 and 2 DS18B20.
The readings are taken every second with the use of the Broker Mosquitto to have a 24 hour history.
I also use the "SMS Free" node to send SMS in case of too low or too high temperature.
Being a new user of Linux and Node-Red, I surely made the system heavier!

I also have a question about my method of installing Node-Red. I use this script found on a tuto : bash <(curl -sl
What do you think?

Surely temperature cannot fluctuate much in 1 second?

Have you tried reducing this to say 30s?

Also, you say 24h history? Where is this historical data saved? In context? 3x60x60x24 == 259200 data points. Are you transmitting these somewhere? Perhaps to a dashboard chart?

That script is the recommended install method for RPI/Ubuntu so I wouldn't be looking there just yet.

I'll test this.

The data is retrieved via Mosquitto so saved on my RPI and visualized on the Node-Red dashboard.

Well if you are sending that amount of data to dashboard every second OR trying to visualise more data than actual pixels, you're asking for trouble :wink:

I overestimated the capabilities of the RPI :wink:
I'm going to lower all this to reduce disk and memory accesses.
I reinstall the system and test without Mosquitto.
Thanks for your support :wink: