Node-red-contrib-alexa-remote2 problems

I have been trying to get this node working, with no success, I keep getting "No csrf found" error when setting up the node. I have tried all the suggestions on the Github issues page too but have had no joy.

Is anyone using this node successfully who could give me a tip?

I'm following this thread. I installed this about 5 days ago and was working fine for a few days. Now I am getting same error you are.

1 Like

JFI Still working fine for me

1 Like

I got mine working following this suggestion in the Node info:

In the imported flow, the Inject Node is set to run at noon on Wednesday, Thursday & Saturday. However, I changed it to run every day at 23:59. I also added another inject node so it will run every time I deploy.

Finally, I put a file name in "File Path" & changed Auto Initialize to Off but I am not 100% sure if necessary.

It has stopped asking me to re-enter my password at 192.168.XXX.XXX:3456 constantly so it seems to be working but it's been less than 12 hours so I don't know if this is a long-term solution. Also, I don't know what was wrong previously so I don't know why this fixed it.

2 Likes

Thank you @stephenn, I tried restarting node-red earlier and it worked!!!!! If it fails again I will try your method!

I had exactly the same problem earlier and after restarting it worked - Thanks to @cymplecy for pointing me in this direction :sunglasses:

1 Like

hi
Anyone seen this file path error before?


nodered is running on unraid docker
Cheers

Looks like you have a permissions problem for the /data directory!

Thanks.
Will double check, but as far as i can tell, it has full permissions

Is the file path name right?

What setup are you running your Node-RED on?

I have node red running in a docker container on unraid
Host container is /data, then mapped to my share folder
In the alexa settings page, if I put anything other than /data I get a file not found error. Putting authFile, results In a enexpected json end error

@cymplecy
Anything else i can check to see why i get this error?
Much appreciated

I know very little about running NR in docker I'm afraid (and no idea what unraid is at all)

Most advice I see on here is to avoid it unless necessary

No dramas, Thanks for answering

That error means you are pointing the file path to a directory. In this case it is the /data directory. You'd need to point it specifically to a file, for example (this is totally arbitrary) /data/amz_auth

That should solve that error message for you or anyone else that's having the issue.

1 Like

Thanks.
I figured out the file path issue and got it working, but only with a USA Amazon account. NOT my Australian Amazon account

Which at this stage, I'm not changing my devices back to USA

Id like to try and get this to work for Australian accounts.
Anyone know how or where in the code the proxy works?
Knowing nothing about the code and/or coding i think i would be way out of my depth, but figured it might be something i can play around with and see how i go!!!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.