Alexa-remote2 nodes issue

Just a heads up - I was documenting how to use the nodes for a blog and went thru setup again and it fails authorising agains Amazon - having spent hours trying to resolve (and having to reset my password in the process) I went to issues on the node and its already been reported

If you follow link to other software using same concept and either speak Deutches or use a translator :slight_smile: - you can see its something to do with changes at Amazon end

So, in the meantime - I think people will be fine for the moment as long as you don't change anything and have to re-auth!
[edit - found the same issue reported further down which says there is an update to the node - just updating now /]

1 Like

Its been fixed #phew with an update

[edit 16Jul 23:06 UK - I'm now thinking its not fixed and that it will need some work to update its main dependacy - still working for me but more by luck I think! /]

It would seem from github issue comments that the maintainer github Apollon77) of the main dependency node (alexa-remote) has fixed the core issue.

But I'm struggling as to howto get this fix into node-red-contrib-alexa-remote2.

Info and hints

but I don't quite know what to do in practice

Tried forking the node on github and changing the dependency version inside package.json and then doing a command line install from my branch but I get error about not being able to remove the node folder :frowning:

Any suggestions npm experts?

It's working here at the moment. I wish it was more stable as it's pretty unique. A little like walking on eggs.

I think if you don't touch it at the moment, it will carry on working - hopefully the cavalry will arrive shortly to help us out - shame the node author seems to be on a sabbatical :slight_smile:

I hope so, Alexa telling me to F..k off is one of my perverse pleasures :slight_smile:

Having issues in Aus too.
I can log in with email, then get an Amazon page saying unavailable

Just tried it...This Alexa node still works (I may regret I said that).
You can run it as a normal user on say port 8980 (I can post details if you need them).

1 Like

Funny Dave, the node description says it needs root access:

"Amazon Echo Hub node is starting a service listening on port 80 which requires Node-Red process to be started with root user."

I used this node a while back and you had to redirect ports. If this has changed it would be a good candidate to control things. No speech output though.

Could we keep this thread to the alexa-remote2 issue please? :slight_smile:

No probs.
I just thought people were interested in hearing about a node that still works.

1 Like

But that node does not have the same functionality.

One is a hue hub local device hack, which creates alexa smart devices

and the other is a full remote control and alexa query functions


I had the same problem with "unable to login VIA [ip address]:3456. I keep getting "There was a problem. Enter a valid email or mobile..."

I just configure the node to use cookie(have to get the cookir first) and it works fine.

I did it on 2 pis, all working good.

I have just checked this morning, and it seems the node is working again (at least for me in Aus) using the proxy method!!

Not saying issue has been fixed (since its been working for me mysteriously for a few days now) but the node author is active on Github so hopefully things will get fixed for everyone :slight_smile:

The alexa-remote2 dependency has been updated to 3.2.6 (which that node's author says fixes the issue) [not yet on npm - so hold off unless your brave and manually update via github] so definitely worth upgrading and trying it out


For those that have it working again.... what's going on with the page for you? Thinking it was a 2FA issue, I've also tried using an authentication app to add a number to the end of my password and I still get the "There was a problem".

For me - it just works with the 3.10.1 version but it shouldn't as its not working for others.

Current status is that the node author has made code changes that SHOULD fix it but hasn't published the new code to the npm catalog yet.

Unfortunately, the author doesn't seem to communicate with people so we don't know when this will happen or whether the code changes will fix the issue.

Someone with the issue could try updating their node direct from github and let us know whether this fixes their problem but no-one has done so yet

Its just been updated :slight_smile:

But not yet in palette :frowning:

But finally here :grinning:


1 Like

Well that did not work.

I think one thing I had to do last week was go thru all my remote2 nodes and reselect my account in them

[edit - but that's not your error so ignore that advice /]

But just to let you know - I have updated my main Win10 with it and stopped/started NR and it all seems to be working still on this machine at least