Alexa Remote2 stops talking

Hi all,
I apologize if this has been addressed in another thread but I couldn't find it if it does exist. I'm running the current version of remote2 and every week or so it'll stop talking. Everything else seems to work fine and the node issues a 'success' result. I've read in other topics that re-deploying or just opening the config node and updating work to correct the issue; and fortunately so far it has. That was the last post on the thread and the thread was closed due to no response. Have there been any revelations, resolutions, or permanent fixes that address this?
Thanks

1 Like

Not as far as I know.

I just use the update workaround when it happens

Ok, thanks for the confirmation.

@wecoyote5 The same thing has happened to me today. I found your post while searching for a solution. I did what you suggest, opened the config node, pressed update and then redeployed.
It has indeed started chatting again.

Is anyone using the Alexa init node or have you selected auto init in the config node?

Yes, auto init is enabled. The weird thing is that the actual Alexa interface works OK so init doesn't look to be needed. I get events and I can ask Alexa to turn off/on something, etc and that works just fine. It just stops talking even though I get a 'success' response, Regardless I setup a daily init now so we'll see what happens.

Yes, Same issue here.
I am have the issue daily. Is made to work again by re-deploying.

I have the init node running once every day... so far it hasn't broken anything so only time will tell if that's keeps her talking.

Well, it hasn't hurt anything but she still stops talking. I'm going to add an on-demand init and just fire that off when she stops.
If anyone comes across a root cause please share :slight_smile:

I have been using a text file.
It stopped talking again today so I have just tried the init node example.

That is not working for me. Each time flow.alexa is injected back into the init note it resets and I am asked to log in??

Edit: I have just retried but deleted the stored flow data first and it works now.

I have to refresh the cookie every 5 mins to avoid this problem.......

I had tried every 300 minutes but still had a speech outage yesterday.

I had the same difficulty today. Here's the debug log of doing a voice response, followed by injecting a refresh cookie request.

10/2/2020, 9:52:50 AMnode: 73b59a5.76a2f64
msg : Object
{ payload: "alexa invertor status", _msgid: "5e3bcad1.8e6084", name: "Drbus", summary: "alexa invertor status" }
10/2/2020, 9:52:50 AMnode: 73b59a5.76a2f64
msg : Object
{ payload: "Inverter is offline", _msgid: "5e3bcad1.8e6084", name: "Drbus", summary: "alexa invertor status", _event: "node:6854b5d0.7666ec" }
10/2/2020, 9:53:23 AMnode: 52f76636.4abf78
msg : string[39]
"failed to load notifications: "Timeout""
10/2/2020, 9:53:23 AMnode: 52f76636.4abf78
msg : string[41]
"failed to load music providers: "Timeout""
10/2/2020, 9:53:23 AMnode: 52f76636.4abf78
msg : string[43]
"failed to load smarthome devices: "Timeout""
10/2/2020, 9:53:33 AMnode: 52f76636.4abf78
msg : string[7]
"Timeout"
10/2/2020, 9:53:34 AMnode: 52f76636.4abf78
msg : string[7]
"Timeout"
10/2/2020, 9:53:34 AMnode: 52f76636.4abf78
msg : string[7]
"Timeout"
10/2/2020, 9:54:24 AMnode: 73b59a5.76a2f64
msg : Object
{ payload: "alexa invertor status", _msgid: "d12e8e64.e19ff", name: "Drbus", summary: "alexa invertor status" }
10/2/2020, 9:54:24 AMnode: 73b59a5.76a2f64
msg : Object
{ payload: "Inverter is offline", _msgid: "d12e8e64.e19ff", name: "Drbus", summary: "alexa invertor status", _event: "node:6854b5d0.7666ec" }

Node-RED Deploy
10/2/2020, 9:56:46 AMnode: 52f76636.4abf78
msg : string[39]
"failed to load notifications: "Timeout""
10/2/2020, 9:56:46 AMnode: 52f76636.4abf78
msg : string[41]
"failed to load music providers: "Timeout""
10/2/2020, 9:56:46 AMnode: 52f76636.4abf78
msg : string[43]
"failed to load smarthome devices: "Timeout""
10/2/2020, 9:56:57 AMnode: 52f76636.4abf78
msg : string[7]
"Timeout"
10/2/2020, 9:56:57 AMnode: 52f76636.4abf78
msg : string[7]
"Timeout"
10/2/2020, 9:56:57 AMnode: 52f76636.4abf78
msg : string[7]
"Timeout"


The refresh cookie operation ultimately finished and then voice response started working again.

I then did another inject to refresh the cookie and got the same timeout errors.

I use my automations in a motorhome with a cellular modem and I power cycled the device.

After which the refresh cookie operation completed with no error messages.

Here's my flow that handles the Alexa interactions.

[{"id":"5513877f.c2dba8","type":"tab","label":"Alexa Voice","disabled":false,"info":""},{"id":"ce26c993.b62fa8","type":"alexa-remote-init","z":"5513877f.c2dba8","name":"","account":"52f76636.4abf78","option":"initialise","x":340,"y":60,"wires":[[]]},{"id":"728c77dd.489fc8","type":"inject","z":"5513877f.c2dba8","name":"FlowStart","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":true,"onceDelay":0.1,"topic":"","payload":"","payloadType":"date","x":120,"y":80,"wires":[["ce26c993.b62fa8"]]},{"id":"90975258.eacd6","type":"alexa-remote-event","z":"5513877f.c2dba8","name":"","account":"52f76636.4abf78","event":"ws-device-activity","x":140,"y":320,"wires":[["2bf60aa8.427f86","24bc3a08.cc3c16"]]},{"id":"76431cb.f7668e4","type":"inject","z":"5513877f.c2dba8","name":"Once a day Refresh","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"00 23 * * *","once":false,"onceDelay":"60","topic":"","payload":"","payloadType":"date","x":160,"y":160,"wires":[["7bb963d9.18ddfc"]]},{"id":"7bb963d9.18ddfc","type":"alexa-remote-init","z":"5513877f.c2dba8","name":"","account":"52f76636.4abf78","option":"refresh","x":370,"y":160,"wires":[[]]},{"id":"5cfd3640.e3b708","type":"change","z":"5513877f.c2dba8","name":"extract summary","rules":[{"t":"set","p":"name","pt":"msg","to":"payload.name","tot":"msg"},{"t":"set","p":"summary","pt":"msg","to":"payload.description.summary","tot":"msg"},{"t":"set","p":"payload","pt":"msg","to":"summary","tot":"msg"}],"action":"","property":"","from":"","to":"","reg":false,"x":350,"y":420,"wires":[["d6a1a083.06837","73b59a5.76a2f64"]]},{"id":"24bc3a08.cc3c16","type":"debug","z":"5513877f.c2dba8","name":"ALL","active":false,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","x":340,"y":260,"wires":[]},{"id":"2bf60aa8.427f86","type":"switch","z":"5513877f.c2dba8","name":"Only pass SUCCESS messages","property":"payload.activityStatus","propertyType":"msg","rules":[{"t":"eq","v":"SUCCESS","vt":"str"}],"checkall":"true","repair":false,"outputs":1,"x":420,"y":320,"wires":[["bc397367.2a4f6"]]},{"id":"bc397367.2a4f6","type":"switch","z":"5513877f.c2dba8","name":"Filter out noise","property":"payload.description.summary","propertyType":"msg","rules":[{"t":"eq","v":"","vt":"str"},{"t":"eq","v":"alexa","vt":"str"},{"t":"else"}],"checkall":"true","repair":false,"outputs":3,"x":130,"y":420,"wires":[[],[],["5cfd3640.e3b708"]]},{"id":"d6a1a083.06837","type":"link out","z":"5513877f.c2dba8","name":"Alexa Voice Request","links":["c13d21e9.f51a1","c4ea40f0.dd73f"],"x":630,"y":420,"wires":[],"l":true},{"id":"73b59a5.76a2f64","type":"debug","z":"5513877f.c2dba8","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","statusVal":"","statusType":"auto","x":540,"y":540,"wires":[]},{"id":"8bc5831a.fff81","type":"link in","z":"5513877f.c2dba8","name":"Alexa Voice Response","links":["72b589cf.0ceff8","f2b54156.7f14b","6854b5d0.7666ec","d1e84629.b856d8"],"x":150,"y":600,"wires":[["73b59a5.76a2f64","f3e8826.9ad648"]],"l":true},{"id":"5538a5b4.3739fc","type":"alexa-remote-routine","z":"5513877f.c2dba8","name":"Acticulate response","account":"52f76636.4abf78","routineNode":{"type":"speak","payload":{"type":"announcement","text":{"type":"msg","value":"payload"},"devices":{"type":"msg","value":"name"}}},"x":420,"y":620,"wires":[[]]},{"id":"f3e8826.9ad648","type":"delay","z":"5513877f.c2dba8","name":"","pauseType":"delay","timeout":"1","timeoutUnits":"seconds","rate":"1","nbRateUnits":"1","rateUnits":"second","randomFirst":"1","randomLast":"5","randomUnits":"seconds","drop":false,"x":350,"y":760,"wires":[["5538a5b4.3739fc"]]},{"id":"52f76636.4abf78","type":"alexa-remote-account","z":"","name":"","authMethod":"proxy","proxyOwnIp":"172.16.14.10","proxyPort":"3456","cookieFile":"/home/pi/.node-red/public/alexa.txt","refreshInterval":"3","alexaServiceHost":"pitangui.amazon.com","amazonPage":"amazon.com","acceptLanguage":"en-US","userAgent":"","useWsMqtt":"on","autoInit":"off"}]

I have it do an init every morning and it talks fairly consistently but it does stop from time to time so I created a virtual device that I can tell Alexa to turn on that will init the interface. So far that works but it'd be nice to know why it stops or to be able to detect that it stops so it can re-init itself. The problem is that the alexa node displays 'success' even though it didn't actually talk.

1 Like

On a related note - my setup wan't working this morning - wasn't even responding to Alexa requests - clicked on my inject to my init node and all came back to life - not seen that one before

@wecoyote5 That's a great idea. How do you create your virtual device?

The ways I know are :

  1. Use alexa-home-skill
  2. Create a routine and then use the alexa-remote2 on device activity node to listen out for that routine.

I use Hubitat as my interface to my sensors/switches/lights, etc. So I created a virtual switch in there (which self resets so it acts like a button... buttons are not supported yet between Hubitat and Alexa) called 'TTS'. This shows up in NR which I then use to fire off the Alexa init. When I say 'Alexa turn TTS on' it resets the interface. I chose this method as it gives me a separate path to inject the init routine. My thought process was that if Alexa isn't talking then I wasn't sure if it would create any events in NR either.

I actually use this method a lot as it also creates a control point in all my automation hardware that I can use anywhere (on my Hubitat Dashboards, Alexa voice control, and/or NR). If you have any automation hardware like Hubitat, Smartthings, etc you should be able to do the same thing. Hope that helps.

If you use the node-red-contrib-alexa-home-skill, there should be no need to create an alexa routine. You should be able to Home-skill switch node as a direct trigger.

@wecoyote5 Many thanks for the reply. That makes sense. I use Domoticz so I think I could do the same in that.
Hopefully this issue will get resolved at some point as is really good otherwise.
@E1cid thanks that was what I was trying to imply. I think for me this is the easiest option.

I noticed a similar issue as well, but a reinitializing does not seem to fix it. Unsure if other commands are broken, but all of the music commands in the echo node for remote2 seem to be broken currently. I use them for volumes per mode in Hubitat and I noticed that is was louder than it should have been for that time.

Anyone else having this same issue? I made an issue on the maintainer's github so hopefully it will get fixed.