Trouble getting started with Alexa-remote

Well I just started today exploiting this Alexa node (so I gues 5.0.7 is the latest Apfelstrudel :wink: ) but I cannot get any spoke Alexa command in NR (using the example flow above from @dynamicdave ).
I am using my iPad with the Alexa App as input device. I dont have any Echo devices yet, still in the testing phase.
My amazon.de accout is fine and "ready to use" as indicated in the node "Alexa Routine"

Actually a real guide or documentation would be really helpful.. I only find examples here and there and mostly about Text to Speech but not Speech-to-NodeRed-Actions ...

What have you tried so far??
Can you post your NR flow??
Here's part of my front-end flow that listens for 'device activity'.
The upper blue node is alexa-remote-init, the lower one is alexa-remote-event.
The top function node captures the 'Alexa device name' so I can send the response back to the source.
Screen Shot 11-24-21 at 05.37 PM

So far I setup the connection to my Alexa Account and tried your example flow from start of the thread. I am running on my local network on a Raspberry 3.
I wonder whether I need to open any ports on my firewall??

Does your 'init' node authenticate with the 'success' indication (as in my exampe above)?

EDIT: Your setup sounds very similar to how I run my system - RPi on a home network.

Actually I just added the init-node which I forgot in my 1.attempt. Its state is "success" returning loginCookie and other session info. However it does not improve anything.
So if network and firewall is not an issue it might be due to my iPad which might not accepted as voice input device? The iPad shows up in the device list though...

I do not have an iPad so cannot comment on that - I use various Alexa devices that work fine.
My grandchildren will be visiting me at the weekend, I'll ask them to bring their iPads so I can check it out.
You may get a response from someone on the forum who has this sort of setup.

1 Like

Hi,
can you fix this error?

JFI I've asked for this thread to be split into its own one as its about setting up Alexa listening from scratch and not the ongoing issues we have from time to time with the remote2 node(s)

The piece of Javascript I listed above was an example of what is in the 'Capture question' function node.
If you want to use it, you'll need to copy-n-paste it in to a function node. It is NOT in json format and was NOT intended to be imported like you are trying to do.

Here's the contents of the function node in jason format, which you should be able to import.

[{"id":"2c68ef53.23d3f8","type":"function","z":"fc2ffed5c7a37e1d","name":"Capture question","func":"var alexa_device_name = msg.payload.name;\nvar summary = msg.payload.description.summary;\n\n if ((summary != \"alexa\") && (summary != \"\")) {\n     \n    msg.payload = {};\n\n    msg = {\n        topic: \"Alexa_response\",\n        device_name: alexa_device_name,\n        payload: {\n            \"summary\": summary\n        }\n    }\n    flow.set(\"alexa_device_name\",alexa_device_name);\n    node.status({text:\"Device_name is \"+ alexa_device_name + \" Summary = \" + summary});\n    return msg;\n}\nelse {\n    return null;\n}","outputs":1,"noerr":0,"initialize":"","finalize":"","libs":[],"x":390,"y":560,"wires":[["962a99e7.3a24d","919a026a168f7e5f","0b32c2a7297d89cc","5b9f3f09a10285ab","da9a0917d09f933d"]]}]

Here's a link to a longer thread about using Alexa and Alexa Skills that you might find useful.

Ok, thank you ....

I noticed that you have this filter .... (summary != "alexa")
but if I don't speak "alexa" first, in debug -> summary I have nothing....

I wrote this code months ago - I think I did it that way to detect the type of Alexa response I needed.

var summary = msg.payload.description.summary;

 if ((summary != "alexa") && (summary != "")) {

I suggest you use a Debug node and inspect what appears in... 'msg.payload.description.summary

1 Like

Ok, I think misread the operating of the function and I try to explain my problem .....

I have one light and with the node alexa event (listening) and a function in node-red if I say "alexa, turn-on the room light", the function in NR turn-on the light .......

But "alexa" don't have a device "room light", so, the light is on but alexa say "sorry, I don't have one device called room light".

Well, I trying to find a way to remove the alexa's answer ....

Thanks a lot for your hints. Meanwhile I tested the node using my Amazon Firestick instead of the iPad - and now it works! :face_with_monocle:
Apparently Amazon does not forward all voice devices to NodeRed...
Ok after this sorted out the fun begins...:wink:

Take a look at creating Custom Q&A with Blueprints
This allows you to create a question and get an answer that you can 'detect or trap' with Node-RED.

Here's an example of saying... "Alexa, open garage door" and getting the response... "ok will do".
Screen Shot 11-25-21 at 10.08 AM

If you want 'fun' - take a look at the link I posted above.

Yep, the "Blueprint" macros are a good start to define a few easy commands. Of course you need to define all possible command variations:
switch on kitchen light - swich on the kitchen light - switch light in kitchen.....
Maybe I forward the text output to some Python script with some more clever text decoding and feed that back into NR...
Thanks again! Have fun!

Yes you need to check for all variations. I've found using 'contains' in a Switch node helps.
Screen Shot 11-25-21 at 10.27 AM

I'll make some test, thank you very much!

Just to complete: after re-installing my iPad "device" on the Amazon user page NR now accepts voice commands. Apparently I had the wrong device "class" defined for the iPad.