Alexa-remote2 not supplying all requests reliably and other issues with it

I've been using alexa-remote2 a bit recently (coupled with the Q&A skill) as per this useful thread

but I'm finding its not quite reliable enough (compared to using @hardillb https://flows.nodered.org/node/node-red-contrib-alexa-home-skill ) for everyday use and I'm wondering is it just my setup or do others have same issue

Basically, I find that if I say "alexa fast forward" - if alexa is successfully triggered, then it picks this the spoken phrase 100% of the time and the activity node outputs the message with the "alexa fast forward" phrase in it and I can control my SkyQ box with it.

Problem is, that it doesn't recognise the wake word 100% of the time (standard alexa behaviour dur to other noises going on) so I like to do it in two stages

E.g say "alexa" then wait for blue circle on my dot - then say "fast forward"

Unfortunately - although it is awake and responds to my command and speaks my chosen Q&A completion phrase so I think it worked - the remote2 activity node doesn't actually output anything in about 50% of cases

If your running the combination of remote2 and Q&A skill - could you test this out and see what results you get?

I just tried with a simple flow with event listener and a debug.
It produced an output on msg.payload.description.summary, 10 out of 10 times and responded with Q&A skill response

This is asking "alexa" then waiting for the blue ring to light up and then asking the rest of your q&a question?

If so - can I ask what your question words were and your response words so I can try an identical test out please :slight_smile:

yes , i said "alexa" then wait, then say "channel one".

i get 3 responses
1 - alexa
2 - channel one
3 - simon says ok

I just edit Q&A
result
1 - alexa 10/10
2 - fast forward 10/10
3 - simon says ok 8/10 but alexa does say ok 10/10

1 Like

OK - I deleted all my questions and just put in channel one with answer ok

I got channel one in msg.payload.description.summary 6 out 10 attempts :frowning:

I wonder why its not reliable for me :frowning:

does alexa respond ok every time?
Is the test flow as simple as possible?
Is your network possibly busy?

Alexa always speaks and says "fast forward ok" (the answer I've set it to)

Just one change node before the debug node to extract msg.pay.desc.summary - lots of nodes after that to react to the message

I disabled the flow and created a new flow with just
image

no difference in loss of messages

There's nothing that I know of that should be hammering it

I have no idea then.

The only other idea i have is -

All my devices except alexa are on ethernet cables not wifi

edit/
if you set debug to all msg, then do you get a msg response?

JFI It's not related to the Q&A skill - I just tried

"alexa"
"what is the time"

and that is just as unreliable in returning the "what is the time" phrase

Having spent a lot of time on this - I'm giving up on the remote2 node - the extra facilities that it gives over using the reliable node-red-contrib-alexa-home-skill from @hardillb isn't worth the unreliability - my family just laugh at me trying to get it to work properly

As they say - I'm out!

Uninstalling it now

well - I couldn't manage to uninstall it so I just left it there :slight_smile:

Was bored so I just tried it again a couple of days ago - and it worked flawlessly!!!!!

Just tried it again today and its working flawlessly still

So - going to reinstate it actually controlling stuff ans see what happens ......

OK - it has worked "quite" well (but not yet good enough for other family members to rely upon)

Current fault is that it doesn't seem to pick up on the 1st time I use a phrase - the Alexa Q&A skill responds but no event is fired by the On Device Activity node.

But once "woken up" it then works at least 9 times out of 10
.
So I decided to trim my NR install from 110 to 18 tabs :slight_smile: yesterday and we'll see if that improves the situation.

Trimmed my tabs down and now its as reliable as I'd expect it to be even on 1st time I use a phrase

And now the gremlins have struck again :frowning:
Its not picking up ANYTHING at all :frowning:
Was working fine until about an hour ago :slight_smile:

My @hardillb stuff is working fine but my remote2 device activity node is pushing out zilch #Crying

[edit] #Phew!

Turns out its just not picking up stuff from my phone - I went into my kitchen and tried using a proper Dot and it works fine!

I did turn on an old phone and enabled Alexa app on that so I'm wondering if that has caused this issue

[/edit]

Just for clarity is your phone on wifi or mobile network?

WiFi - like I say, the @hardillb node is picking up commands but the remote2 one is deaf to them.

I'm just trying switching off all phones and switching only one of them back on.......but that's made no diff

At least its still working in the kitchen where it matters but its done in my testing at the computer :frowning:

Just tried the Alexa app on my computer and at least that still works
image

but I'd stopped using that as I find it more convenient to just use a phone rather than having to press some keys on my computer while I'm developing stuff

mmm - I just tried another phone and that one is working - I wonder if remote2 doesn't deal with multiple Alexa apps running on android phones.

I "thought" I had it working on two of my phones but maybe my memory is tricking me and it NEVER did.

I'll just stick with using it on this one phone for a while and remove the app on the other two

In the app under devices - echo & alexa
does the phone show up?

Well - I've just uninstalled it from the other phones but on the one that works its there