Node-red-contrib-arangodb error

I am using node-red-contrib-arangodb. I have configured my database like this:


when I deploy I get this error
Error: getaddrinfo ENOTFOUND http

Hi @Monta,

i have never used that node so cannot comment on it directly, but the url you have used has too many http in it and is not valid.

You probably want to use:


Thank you @knolleary.
Now I got a new error: it doesn't now the path. I am sure it is correct because I use the same url when I use curl

In node-red you are trying to use a contrib-node not a http node. Have you tried to search to see if there are any examples?

Indeed, I am using this contrib-node:

That's an example flow (rather than a node) have you tried importing the flow on that page and looking to see how the flow sends it data?

If you still can't work out how to do it I would suggest opening an issue on the nodes github page, as a node should contain enough information in the ReadMe to allow you to configure the node.

I imported the flow as it is and added database config. However, it doesn't work.

As the node itself isn’t published on I’m guessing it is not widely used by people on the forum site.

As I already suggested, you could try contacting the owner by opening an issue on the nodes github page.