Node-red-contrib-ds18b20 with "bullseye"

I have just upgraded to Bulleye and pulled over some flows including "node-red-contrib-d18b20"
It will not find an Id for the device or provide an output and yes I have enabled 1-wire.
Anyone with similar issues?

You might want to try one of the other ds18b20 nodes seeing that node-red-contrib-d18b20 hasn't been updated in over 9 years.

Also how do you have it connected to your pi?

I've tried all of them with same result. Some sort of conflict maybe? I don't know how to find it.

I've going to set up a test but I'll be out for about an hour before I can build it. so check back in about 3 hours

What model Pi are you running on?

@muggins one more thing, can you send a circuit diagram of how you have it setup.

Its a PI 4 and wired as per

You said you upgraded to bullseye. Do you mean the same hardware and node worked with the sensor before you upgraded?

Hardware and node exactly as before. I can swap back to Buster and it works first time.

In a command window stop node-red using
then start again using
and post the full output here.

pi@testPI:~ $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser

Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to

Starting as a systemd service.
10 Jul 21:59:24 - [info]
Welcome to Node-RED
10 Jul 21:59:24 - [info] Node-RED version: v3.0.2
10 Jul 21:59:24 - [info] Node.js  version: v16.20.1
10 Jul 21:59:24 - [info] Linux 6.1.21-v8+ arm64 LE
10 Jul 21:59:26 - [info] Loading palette nodes
rpi_ds18b20_s64.node driver V2.0.1 (c) Ocean
10 Jul 21:59:29 - [info] Worldmap version 2.37.4
10 Jul 21:59:29 - [info] Dashboard version 3.5.0 started at /ui
10 Jul 21:59:30 - [info] Settings file  : /home/pi/.node-red/settings.js
10 Jul 21:59:30 - [info] Context store  : 'default' [module=memory]
10 Jul 21:59:30 - [info] User directory : /home/pi/.node-red
10 Jul 21:59:30 - [warn] Projects disabled : editorTheme.projects.enabled=false
10 Jul 21:59:30 - [info] Flows file     : /home/pi/.node-red/flows.json
10 Jul 21:59:30 - [info] Server now running at
10 Jul 21:59:30 - [warn]
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
10 Jul 21:59:30 - [info] Starting flows
10 Jul 21:59:30 - [info] [tcp out:telnet] connecting to localhost:7072
10 Jul 21:59:31 - [info] [tcp out:telnet] connecting to localhost:7072
10 Jul 21:59:31 - [info] [worldmap:ea01c54a6765424c] started at /worldmap
10 Jul 21:59:31 - [info] Started flows
10 Jul 21:59:31 - [info] [aedes broker:AEDES MQTT] Binding aedes mqtt server on port: 1884
10 Jul 21:59:31 - [info] [serialconfig:9d5f7edf.fec6f] serial port /dev/ttyUSB0 opened at 9600 baud 8N1
10 Jul 21:59:31 - [info] [sqlitedb:c37d97a8.1b07c8] opened /home/pi/dbs/iot.db ok
10 Jul 21:59:31 - [info] [mqtt-broker:THIS PI] Connected to broker: mqtt://
10 Jul 21:59:31 - [info] [tcp out:telnet] connected to localhost:7072
10 Jul 21:59:31 - [info] [tcp out:telnet] connected to localhost:7072
10 Jul 21:59:31 - [info] [mqtt-broker:Attic Pi] Connected to broker: mqtt://
10 Jul 21:59:31 - [info] [mqtt-broker:OTHER PI] Connected to broker: mqtt://
10 Jul 21:59:31 - [info] [alexa-remote-account:e8dcc463bf8647c4] intialising with the PROXY method and saved data...
10 Jul 21:59:31 - [info] [mqtt-broker:cloud-MQTT] Connected to broker: mqtt://
10 Jul 21:59:32 - [info] [mqtt-broker:Beebotte] Connected to broker: mqtt://
10 Jul 21:59:33 - [warn] [alexa-remote-account:e8dcc463bf8647c4] EACCES: permission denied, open '/home/pi/alexa-speak'

I seem to remember that you can see the 1-wire devices in one of the sys folders, it is late here so I can't look it up at the moment. See if they are there. It sounds most likely to be something missing from the bullseye setup for 1-wire, rather than a node-red issue.

Ok, I just set up a DS18B20 on a Pi 3 Model B Rev 1.2 with bullseye. In a terminal I ran:

Last login: Mon Jul 10 17:31:43 2023
pmw@testpi:~ $ lsmod | grep w1
w1_therm 28672 0
w1_gpio 16384 0
wire 36864 2 w1_gpio,w1_therm
pmw@testpi:~ $ cd /sys/bus/w1/devices
pmw@testpi:/sys/bus/w1/devices $ ls
28-fd71e70264ff w1_bus_master1
pmw@testpi:/sys/bus/w1/devices $ cd 28-fd71e70264ff
pmw@testpi:/sys/bus/w1/devices/28-fd71e70264ff $ cat w1_slave
92 01 55 00 7f ff 0c 10 88 : crc=88 YES
92 01 55 00 7f ff 0c 10 88 t=25125

You can see that data was returned (t=25125)

I then built a flow using node-red-contrib-ds18b20 and here is the result:

You can see it is working.

  1. You say you are running Bullseye but are you running the 32 or 64 bit version?
  2. In your startup log I see:
    rpi_ds18b20_s64.node driver V2.0.1 (c) Ocean
    which node are you currently using?

This is what I get and does not look right. I'm running 64 bit node 16.20.1

pi@testPI:~ $ lsmod | grep w1
w1_therm               28672  0
w1_gpio                16384  0
wire                   49152  2 w1_gpio,w1_therm
pi@testPI:~ $ cd /sys/bus/w1/devices
pi@testPI:/sys/bus/w1/devices $ ls
00-710000000000  00-f10000000000  w1_bus_master1

what do you see if you issue
cd 00-710000000000
cat w1_slave

I wonder if it is a 32 vrs 64 bit issue.

I ran a 1820 sensor for a long time on a 64 bit pi 4, I changed over to different sensors and don't have the exact node I used but I do remember going through more than a few to find one that worked

Deepest apologies for wasting all your time. I have a quite convoluted set up with all sorts including serial connection to my alarm system. About 5 years ago I had to move the DS18B20 pin to accomodate something else and have since forgotten about it. So
has sorted it.
I'm very sorry... getting old.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.