Node red contrib OLED, can't download nodes

I have not been successful in using nodes associated with OLED.
Either OLED node and dependencies won't install , or if they do install cannot use them in a flow as they throw up error messages. Have tried upgrading npm and Node.js, still no success. Is there now an underlying problem with acquiring the Node Red Oled node and dependencies. Any help would be appreciated.

Which libraries?

What are the errors.

When I was able to download I get this error message, “TypeError: Cannot read property ‘setCursor, of undefined”
Another error I get
“Error:ENOENT: no such file or directory, open ‘/dev/i2c-1’”

which nodes?

Please identify them for us in the flow library. That way, anyone who has had this issue before can assist.

What versions were you on. What version are you on now? This is important info as some nodes have problems with some versions of node.

Without knowing which nodes. This is quite meaningless.

Hi Stephen
Thanks for your interest.
The version of Node Red I am using is v1.0.3
The node causing the problem is the String Node in the OLED group.
The flow is simple and involves an inject, function as well as the String
I am following the YouTube video "RPi Node-Red:OLED Display by T3 Alliance.
I confess to being a bit of a Newbie, but I hope that is what you are after.
Cheers Neil

We were all newbies at one time :slight_smile:

Unfortunately that is not what people would need to help you.

that makes no sense I'm afraid.

You need to identify the node in the flow library so anyone else using it can see its the same one - then they (might) be able to help or point you in the right direction...

which node?

Additionally, when you see an error - if you can copy the error message as text, its best to paste it into the forum like this

code / json / error info here between backticks

Also, screenshots showing where errors occured (was it in console? in node-red debug window?) etc.

@Steve-Mcl Steve, the OLED node installs 12 nodes and one is a 'String` node

@nobb26 what platform are you running NR on?
Is the OLED connected to that device?
Have you been able to get the OLED to work outside of Node-RED?

Thats all good and well - but which node did he install in node red? I can assume but you know what they say about that. :wink:

Once the OP identifies it, I would instruct him to look in the nodes repository for issues / solutions & if none, then to raise an issue.


If we assume it is node-red-contrib-oled then looking at the package there is no mention of this "String" node the only deps i see are

"dependencies": {
    "i2c-bus": "^5.1.0",
    "oled-font-5x7": "^1.0.3",
    "oled-i2c-bus": "^3.0.1"

(nothing to say one of those deps dont require something called string however)

But thats why I asked which node.

And heres another oddity - the oled-i2c-bus is requiring V3.0.1 however on NPM there is only V1.0.11

Additionally, "node-red-contrib-oled" has barely been touched in 3y

Lastly, i2c-bus has a minor version update too (v5.2.0)

If I were to need this - I'd likely fork it.

The node is node-red-contrib-oled and it installs 12 nodes

And there is a report in GitHub of a problem installing the node

1 Like

It was the String Node from the OLED group. These are the flow details.

[{"id":"86a9b74a.3a40f8","type":"tab","label":"Flow 1","disabled":false,"info":""},{"id":"a3e4da6a.9f8cc8","type":"inject","z":"86a9b74a.3a40f8","name":"","topic":"","payload":"Hello world","payloadType":"str","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":120,"y":120,"wires":[["b1ff9794.fec0e8"]]},{"id":"b1ff9794.fec0e8","type":"function","z":"86a9b74a.3a40f8","name":"Format message","func":"msg.payload = {\n x:1,\n y:50,\n text:msg.payload\n}\nreturn msg;","outputs":1,"noerr":0,"x":430,"y":160,"wires":[["6ed6125e.9b8c7c"]]},{"id":"6ed6125e.9b8c7c","type":"String","z":"86a9b74a.3a40f8","name":"OLED","display":"242fdfa3.047e5","x":660,"y":200,"wires":},{"id":"242fdfa3.047e5","type":"oled-config","z":"","name":"","width":"128","height":"64","address":"3c"}]

I am using Node Red on Raspberry Pi Buster.
Hope that helps. Thanks again for your interest and time.

I dont see any issue about the package pointing to a non existent version of oled-i2c-bus

on 4th Apr, the dev updated packages & change if from V1.0.10 to V3.0.1 - I suspect that is an error since the highest version of oled-i2c-bus is V1.0.11

Then again, I have just noticed in flow library it shows V0.1.0 and not updated for 2years - so this might be a red herring (until he publishes to NPM)

@nobb26 you could try updating package.json manually & npm install

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.