Has anyone got node-red-contrib-puppeteer-new to work?

Unfortunately there are no instructions for this.

Is that possible or do you have to install something afterwards?

I tried quite a few ways of using puppeteer from NodeRED but the only one that worked for me was to call an external node.js script and then load in data from files that it generated - very very rough solution

i am not sure about this node - I have extended the puppeteer node which was the only one there I guess (added ability for dynamic data inputs, and many other enhancements) and had a large project with it - I always meant to upload my version to Github but haven't done that.. looks like someone has beat me to it! I can possibly help as my nodes worked nicely for my project and used to do things like login, navigate , paginate, and all sort of magic ... I can look into it if there is interest

1 Like

Any working node would be great :slight_smile:

actually I realised I have it in github already.. thing is I dont remember how this package came together , it is a fork from NewNoetic/node-red-contrib-puppeteer-alpine
, however, I renamed it to node-red-contrib-puppeteer-core-chromium .. I don't exactly remember why, but I had a good reason to do so :slight_smile:
give this one a go , however, it is not on npm and so not in flows library, reason is because the node name actually exists there - sorry it is confusing but something that can be fixed later..

npm install

1 Like

just tested my old flow - still works with the node - so if you face issues let me know..
the flow should start with a Browser , you can run in either headless mode or not , then add nodes such as newPage, goto , etc. it is really simple to use actually..
the selectors can come from msg etc.
I may make some tweaks on it and change package name using new node-red conventions ..


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.