Node-red-contrib-shelly 4.1.4 install failed


does somebody uses the node-red-shelly? I installed to 4.14 and it failed:
Error code:
022-02-07T20:46:19.146Z installieren : node-red-contrib-shelly 4.1.4
2022-02-07T20:46:19.382Z npm install --no-package-lock --global-style --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production node-red-contrib-shelly@4.1.4
2022-02-07T20:46:28.498Z [out]
2022-02-07T20:46:28.498Z [out] up to date in 8s
2022-02-07T20:46:28.521Z rc=0

Even my previous version is gone and I don't have any shelly node in my Node-Red.

What can I do? Or at least how can I get the previous version back?


That is telling you that it is already installed. Try restarting node-red, clear the cache in the browser (via the browser menus) and refresh the editor page. If still not working stop node red and start it again in a terminal and post the terminal output here.

Ok, it seems to be it is installed but I can't see any Shelly node. I restarted several times, cleaned up cache, but always the same error. Used different browser as well.
Now I'll figure out what terminal means. My node-Red is running on a CCU3.

Well normally that means a window where you type commands with a keyboard. How that relates to your setup I don't know.

Do you mean during start the Red-Node watching a terminal?

Otherwise I attached the screenshot terminal from the install.

I meant to stop node red then run the command to start node red so that you see the node red startup messages, and copy/paste the output here. You should see a Welcome to node red message at the start.

I can download a log file, but before I have to chose the log level. What makes the most sense?

Log level info, which is the default for a normal install on a PC or Pi.

Here you go. I can see the Shelly Node is on the start list but not in the system "Palette"?

You may have to ask on a forum specific to this device. You should see a log starting with something like

Welcome to Node-RED
[info] Node-RED version: v2.2.0
[info] Node.js  version: v16.14.0
[info] Linux 5.4.0-97-generic x64 LE
[info] Loading palette nodes
[info] Dashboard version 3.1.2 started at /ui

I checked the log error and found this:
[node-red-contrib-shelly] Node module cannot be loaded on this version. Requires: >=1.3.7
Feb 10 06:53:04 ccu3-webui daemon.warn node-red[32638]: [node-red-contrib-telegrambot] Node module cannot be loaded on this version. Requires: >=1.3.7

So it looks like my Node Red version is not correct:

redmatic": "7.2.1",
"nodejs": "14.16.0",
"@node-red-contrib-themes/midnight-red": "1.4.7",
"ain2": "3.0.0",
"node-red": "1.2.9",
"npm": "7.6.3",
"node-red-contrib-cast": "0.2.17",
"node-red-contrib-ccu": "3.4.2",
"node-red-contrib-chromecast": "0.0.1",

I think I have version 1.2.9 or?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.