Node-red-contrib-tesla setScheduldedDeparture: TypeError: tjs.setScheduledDepartureAsync is not a function

Hi, I'm building a simple solution to turn on ScheduledDeparture for one day only (which the Tesla app cannot do).

flow is simple: setScheduledDeparture on, wait for next day, setScheduledDeparture off

My problem: the tesla node throws

TypeError: tjs.setScheduledDepartureAsync is not a function

My setup:

  • the node is configured, selected command is " setScheduledDeparture".
  • I inject this message
  • I also tried with only one commandArgs: "enable", still not working, same error
  • I also tried with no commandArgs and get another error: "TypeError: Cannot read property 'enable' of undefined" (which is expected)
  • every other tesla node (eg setChargeLimit) is working
  • car is awake

Any hint where to start debugging?

Are you using the latest version of this node?

node-red-contrib-tesla 2.0.0 on node red 2.1.5

Can anyone please confirm that the node is working with setScheduledDeparture and post a working json for the parameter?



I tried just with enable, and it is not working for me. I also tried the same command with setScheduledCharging, and it is working.

Using version 2.0 and Nodered 2.1.4


Thanks for confirming. I created an issue on Github.

Use the compatible teslajs library I have updated (@gaphi/teslajs). The pull to the main branch is not available yet I think.

This command works perfectly as I use it every day with a much more complex logic (use my Google calendar events, electricity tariff, location of the car, day-off, state of the car, etc...)

so I should use your node red node (1.0.6-0) instead of the regular (2.0.0)? Does it have auto-wakeup already?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.