Node red debug core node missing after installation win 8.1

#1

I am new to node red. I have installed nodejs version 8.9.3 and npm version 6.3.0 on windows 8.1. For some reason debug and inject core modules were missing. I have installed the inject node using npm insall command however i could not install/find debug module . Any help will much appreciated.

#2

Hi. The inject and debug nodes are not available as separately installed modules.

What module did you install?

It would be worth trying to identify where your node-red install is going wrong to be missing those nodes.

Do you get any error messages in the node-red log when you run?

#3

Thanks for quick response. Initially i did not install any seperate module except dash board. I followed the guide lines described https://nodered.org/docs/platforms/windows

#4

I would like to add one more thing, i have installed using windows installer package available on nodejs.org

#5

You said here you installed a module to get the inject node. What module was that?

And again, what does node-red output when you start it?

#6

Many thanks for the support.
The problem already existed before i installed any modules i.e just after running the installer and installing node red using npm install -g --unsafe-perm node-red
I think i used npm install node-red-contrib-reinject to install inject node. I also tried to install raspberry pi node, though i dont have it.
Below is the output when i start node-red

Welcome to Node-RED

===================

15 Aug 20:57:28 - [info] Node-RED version: v0.19.0

15 Aug 20:57:28 - [info] Node.js version: v8.9.3

15 Aug 20:57:28 - [info] Windows_NT 6.3.9600 x64 LE

15 Aug 20:57:29 - [info] Loading palette nodes

15 Aug 20:57:34 - [warn] rpi-gpio : Raspberry Pi specific node set inactive

15 Aug 20:57:42 - [info] Dashboard version 2.9.6 started at /ui

15 Aug 20:57:43 - [warn] ------------------------------------------------------

15 Aug 20:57:43 - [warn] [node-red/tail] Not currently supported on Windows.

15 Aug 20:57:43 - [warn] [node-red-contrib-homekit/homekit] Type already registe

red

15 Aug 20:57:43 - [warn] ------------------------------------------------------

15 Aug 20:57:43 - [info] Settings file : C:\Users\digitallearner\AppData\Roaming\SPB_16

.6.node-red\settings.js

15 Aug 20:57:43 - [info] Context store : 'default' [module=memory]

15 Aug 20:57:43 - [info] User directory : C:\Users\digitallearner\AppData\Roaming\SPB_16

.6.node-red

15 Aug 20:57:43 - [warn] Projects disabled : editorTheme.projects.enabled=false

15 Aug 20:57:43 - [info] Flows file : C:\Users\digitallearner\AppData\Roaming\SPB_16

.6.node-red\flows_HP.json

15 Aug 20:57:43 - [warn]


Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials

file will not be recoverable, you will have to delete it and re-enter

your credentials.

You should set your own key using the 'credentialSecret' option in

your settings file. Node-RED will then re-encrypt your credentials

file using your chosen key the next time you deploy a change.


15 Aug 20:57:43 - [info] Starting flows

15 Aug 20:57:43 - [info] Started flows

15 Aug 20:57:43 - [info] Server now running at http://127.0.0.1:1880/

#7

node-red-contrib-reinject is not the core inject node. It's some random 3rd-party contributed node.

There are no obvious errors in that log to indicate why the inject or debug nodes would be missing. The next thing to check is the browser javascript console.

#8

I am using chrome. I have open the console. In the console i got the following.
Node-RED: 0.19.0 red.min.js:16
Projects disabled main.min.js:16
Could you please guide me what could be done here to debug this issue
Thanks

#9

Well, yes, that is what I'm trying to do.

But right now, I'm not sure what to suggest. I can't think of any reason why the Inject/Debug nodes would fail to load without there being any error message in either the runtime log or browser. I'm not sure we've ever seen that happen.

Can you share a screenshot of the editor?

#10


Could it be because of antivirus/firewall settings

#11

i used node-red-admin to check see the list of nodes installed. For some reason debug and inject nodes are disabled. debug_inject_missing_list

1 Like
#12

I enabled the nodes and now it works. I am not sure why they were disabled from the beginning. I am so very great full for all the support.